Emails unable to send

My prior email server has had issues sending emails, unable to find solutions, so i ran up a brand new instance on Vultr of Cyberpanel, latest versions etc, setup everything, SSLs etc, DNS all correct, added new website with Mail server, submitted correct SSL for mail server. Added email account, logged into loopmail, tried to send an email and fails to send!

Stumped at why this doesnt just work when everything is setup correctly, i have setup cyberpanel 6 times on version 2.1.1 and it worked fine.

Are you sure port 25 smtp relay access is unblocked for your server ip? Please confirm it from your hosting provider.

Also for smtp outgoing mails to work, you need to setup rDNS from the server side. Also the rDNS should have an A record entry in the DNS. Please make sure its all correct.

Then, use tools like mxtoolbox website to check if your setup is correct and you aren’t missing on any configuration.

Yes everything is setup correctly, Vultr doesnt restrict port 25 and they have confirmed this plus i have other servers with them that work fine even with cyberpanel version 2.1.1

My mail issues started randomly 5 days ago on my cyberpanel mail server, i have had no end of issues trying to fix issues to the point i decided to start a fresh install brand new server and still doesnt work.

when running: sudo systemctl list-units --state=failed
i get 2 failed services, i noticed this from as soon as the server was setup with cyberpanel

UNIT LOAD ACTIVE SUB DESCRIPTION
● cpecs.service loaded failed failed CyberPanel Email Policy Control Daemon
● rc-local.service loaded failed failed /etc/rc.local Compatibility

LOAD = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB = The low-level unit activation state, values depend on unit type.

2 loaded units listed.

Could this be a reason why?

I will advise you to connect your cyberpanel server having this mail issue to Cyberpanel cloud and then run the Email debugger option available there. If it shows as not available to you, then open a support ticket requesting for email debugger access. It will be enabled for FREE.

Email debugger function of Cyberpanel cloud will reinstall and reset all mailserver related files in server clearing out almost all issues.

Also check in mxtoolbox website for any potential configuration error you may have done by any chance. It will help you to identify the reason for your email issues.

The problem with connecting to Cyberpanel cloud is that is also bugged and causes issues, i removed all connections due to this. Plus i use my email server and my hosting servers separately and concerned any email debugger wouldnt take this into account.

Can you at least confirm if the 2 failed services are normal?

Also would you advise a fresh install of Cyberpanel be done from command line on a fresh Ubuntu 20.04 or using the market place app on vultr?

I just want a working Cyberpanel install from the start!!!

I will never suggest you to have cyberpanel installed from hosting provider’s custom image. Nor the developers of cyberpanel would suggest that way.

The only best way to install cyberpanel is to install it from ssh by pasting the one line installation command to ssh.

Have you installed Email policy server? Those failed services are of email policy server

I have just removed the latest instance on Vultr which was installed using the custom image, i am now starting with a new fresh ubuntu 20.40 install and will take the ssh command line method and then check for any failed services and get back to you. I hope this works because it has caused me no end of issues!

1 Like

Thats true, I also personally recommend to always install manually.

1 Like

So as advised i have made a completely new Vultr VPS instance on Ubuntu 20.04, i then installed Cyberpanel from command line. Then i ran sudo systemctl list-units --state=failed

I now have 3 failed services not 2

UNIT LOAD ACTIVE SUB DESCRIPTION
● console-setup.service loaded failed failed Set console font and keymap
● opendkim.service loaded failed failed OpenDKIM DomainKeys Identified Mail (DKIM) Milter
● rc-local.service loaded failed failed /etc/rc.local Compatibility

LOAD = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB = The low-level unit activation state, values depend on unit type.

3 loaded units listed.

Please advise if this is normal

The failed state error console-setup.service should be solved mostly by a server restart.
This has nothing to do with your email issue.

The second failed state error is for DKIM generation. Yes, this impacts email services in email delivery SPAM. Still your emails should be sent successfully but it maybe mostly delivered in spam.

The 3rd failed state error can be ignored.

If you can send me a private message with your domain name and the DNS entries for the domain and what entry it is added for rDNS, then I can analyze and guide you in better path for solution.

I have a very similar problem, I receive but do not send email

thank you

More details on your setup please?

i got a reply from vultr stating that all smtp ports are blocked.(Thank you for contacting the Vultr Technical Support team.

While we do block SMTP ports by default, this block may be lifted by our Account Management team on a case-by-case basis. We are forwarding this request to our Account Management team for review, and they will work as swiftly as possible to address your inquiry.)
I answered a questionnaire and I’m waiting before reinstalling the server.

Vultr literally replied to me 5 hours ago

“Thank you for your inquiry.
We are not blocking port 25 on the referenced instance.”

At no point have i asked them to unblock port 25 so it must have been unblocked as default.

Im no wondering if my other instances are blocked

You need to be sure about port 25 block on the server hosting site. You can always contact them and ask for the same.
Remember, the port block is assigned to server ip and not on account level. It all depends on the hosting provider how this is done. In Amazon AWS, Google Cloud, Oracle Cloud, its all per IP based block. For each server ip, we need to contact support to unblock it.

For Upcloud hosting provider, its account level block and if the block is lifted then all server ips are unblocked.

Dont have knowledge about how Vultr does this. But I believe its per IP level and you will need to contact them to unblock on each IP

waiting for response from vultr to release SMTP ports.

I answered a questionnaire about using email.

I asked host unable to send email what purpose is it?

as soon as the vult responds…
it works warning

does not work warning

thanks

1 Like

vultr does not release SMTP ports and continues interrogating, see! (Can you please provide in as much detail as possible, the nature of the emails you intend to send. Please confirm if the emails you will be sending will include marketing promotions, newsletters, coupons , account related notification, etcetera.)

I will have to change servers

Tell them you will be using it for transactional mails only. They will approve it.

use the command via terminal or ssh

netstat -an | grep :25

example:

netstat -an | grep :(enter the port to query)

it was very useful to me

1 Like