Email Set-up POSTFIX relay access denied

Hi all,

First off, forgive me. I am a total newbie. Foolishly wandering into the world of a self-managed vps with godaddy.

  1. One IP address
    2.Installed Cyberpanel and Litespeed Ent on Siteowner license (5 domains)

All seems fine EXCEPT email.

I have set up one domain so far, pointed the godaddy dns at the IP its hosted on, and website works.

I have then created email in cyberpanel for that website and added:

  1. DMARC, SPF and DEFAULTKEY, and DKIM entries as per the cyberpanel documentation, on the godaddy dns server.

  2. I now can only send and receive emails via Rainloop INTERNALLY. NO external sending or receiving.

I have read the cyberpanel guides the past week and tried everything that I can understand. So far no joy.

Reverse DNS seems to be the main problem that I needed to work around. In cyberpanel documentation, it says to get reverse DNS setup by ISP. However, godaddy refuse to help as its self-managed. Seems my server relay is a set up by godaddy. I contacted the reverse DNS hostname owners and they cannot help as its… yep… self managed!

So here is the issue:

My mail server is hosted by Godaddy, I cannot get ReverseDNS setup to point at my IP domain, or virtual host domain name.

When runnning MXtoolbox test email server, it kept flagging SMTP Banner MISMATCH.

So, I edited:

FROM: myhostname =
TO: myhostname =

in etc/postfix/

That solved the Banner MISMATCH error, but did not resolve emails not sending/receiving EXTERNALLY.

Can anyone help? I tried tickets at cyberpanel, and it seems I need to pay fees for them to either do the fix, or “talk through” it.

That doesnt help me learn how this server stuff works, and I need to figure it out so I can run my own sites myself.

Here is some more pertinent (i hope) information:

  1. When running MXToolBox Test Email Server, I now get the following:

220 ESMTP Postfix
Test Result

SMTP Reverse DNS Mismatch OK - resolves to
SMTP Valid Hostname OK - Reverse DNS is a valid Hostname
SMTP Banner Check OK - Reverse DNS matches SMTP Banner
SMTP TLS OK - Supports TLS.
SMTP Connection Time 0.898 seconds - Good on Connection time
SMTP Open Relay OK - Not an open relay.
SMTP Transaction Time 3.120 seconds - Good on Transaction Time
Session Transcript:
Connecting to

220 ESMTP Postfix [773 ms]
250-SIZE 30720000
250 DSN [710 ms]
250 2.1.0 Ok [708 ms]
454 4.7.1 Relay access denied [711 ms]

LookupServer 3604ms

And reading more around it, it seems this Relay Access Denied is the issue I need to fix somehow.

However, I am not entirely sure, also in command line when I run:
postfix reload,

The following errors are flagged by postfix:

/usr/sbin/postconf: warning: /etc/postfix/ undefined parameter: mua_sender_restrictions
/usr/sbin/postconf: warning: /etc/postfix/ undefined parameter: mua_client_restrictions
/usr/sbin/postconf: warning: /etc/postfix/ undefined parameter: mua_helo_restrictions
/usr/sbin/postconf: warning: /etc/postfix/ undefined parameter: mua_sender_restrictions
/usr/sbin/postconf: warning: /etc/postfix/ undefined parameter: mua_client_restrictions
/usr/sbin/postconf: warning: /etc/postfix/ undefined parameter: mua_helo_restrictions
/usr/sbin/postconf: warning: /etc/postfix/ undefined parameter: virtual_mailbox_limit_maps
/usr/sbin/postconf: warning: /etc/postfix/ unused parameter: virtual_create_maildirsize=yes
/usr/sbin/postconf: warning: /etc/postfix/ unused parameter: virtual_maildir_extended=yes

So maybe these are issues I need to address?

Can anyone help a total newbie (in a step by step, easy to follow guide) on how to resolve this email sending issue?

A brief recap of what the problem is:

  1. Self managed VPS on godaddy. 1 IP address. Reverse DNS (set up by godaddy not me) has that IP address resolving to this hostname:
  2. I cannot change above hostname, and GoDaddy and IP owners both say they cannot change them?
  3. My email account created in Cyberpanel, only sends and receives to itself, internally.
  4. There are no bounce back replies on sending emails externally, or to external recipient addresses sending emails to it. They just get sent but never arrive.
  5. I fixed the SMTP Banner Mismatch problem, by replacing email domain name with above hostname in myhostname = field, in in postfix.
  6. Errors posted above from Test Email Server tool on mxtoolbox.
  7. Errors posted above that are displayed on running postfix reload command in terminal.

Any help MUCH appreciated. Thanks for reading.

@usmannasir Hi usman, can you help out with this? I am 7 days in to moving to cyberpanel and still do not have a fully functional server? Thanks in advance.

have had no feedback from support tickets x 3 opened on this. I will be closing cyberpanel account and lsws account.