Email Headers missing "Received:" header

Incoming email headers appear to be missing “Received:” headers which indicate the IP address of the server contacting us.

HERE IS AN EXAMPLE:

Return-Path: <xxxxx@xyznetworks.com>
Delivered-To: support@mydomain.com
X-Spam-Checker-Version: SpamAssassin 3.4.4 (2020-01-24) on lx1.pgssl.com
X-Spam-Level: *
X-Spam-Status: No, score=1.5 required=3.0 tests=BITCOIN_ONAN,NO_RECEIVED,
	NO_RELAYS,PDS_BTC_ID,T_SCC_BODY_TEXT_LINE autolearn=no
	autolearn_force=no version=3.4.4
From: <xxxxx@xyznetworks.com>
To: <support@mydomain.com>
Subject: Example subject line here
Date: 3 May 2022 18:09:12 -0400
Message-ID: <004601d85f3e$0105c685$cb799592$@oxynetworks.com>
MIME-Version: 1.0
Content-Type: text/plain;
	charset="windows-1250"
Content-Transfer-Encoding: 8bit
X-Mailer: Microsoft Office Outlook 12.0
Thread-Index: Acvhw33ryc1n59lhvhw33ryc1n59lh==
Content-Language: en

Is this by default? How do I add “Received” headers to CyberPanel so that we can identify what server/IP our incoming emails originated from?

Running latest Cyberpanel version 2.3

Does anyone else have the same problem? Did I miss a setting somewhere?