Email Drama

I installed Cyberpanel on two servers most recently. (I’m new to unmanaged VPS systems).

On my first install (CentOS) I had an SMTP problem, could not send but could receive and wasn’t getting any errors.

I discovered that PORT 25 was blocked and that my configuration for Cyberpanel was setup to use Port 25. So, as a work around I went through SENDGRID and integrated their service into my VPS (via postfix). It now works fine, however having to go through an external SMTP service just seemed to much work! For each domain, I’d have to sign up for an account, setup this and that… it was a big bother.

For my 2nd VPS Cyberpanel (Ubuntu 18x because 20 just would not install - version not detected issues). I setup everything, and Ubuntu just seemed to run even smoother to be honest. Then came the e-mail setup.

  1. I can’t even LOGIN to Rainloop
  2. I’ve been through the rainloop/?admin tried all of the troubleshooting with zero luck
  3. I CANNOT find the log file for rainloop? All the other control panel’s have one, but cyberpanel seems to not?

After discovering the RAINLOOP admin panel, i discovered that you could configure domain SMTP settings, so now setting up an external sendgrid based smtp would be easier? But of course that whole signup process is just too hard. Then i thought, if i could get this LOGIN working at least, maybe i can force SMTP port 587 so it works, because 587 IS NOT Blocked on my server.

I played around and discovered that no matter what I do (SSL wise) it gives me an SMTP error.
Error 1 (ssl) stream_socket_client(): SSL: Connection reset by peer
Error 2 (tls) 454 4.7.0 TLS not available due to local problem

So here are my questions:

  1. Where is the rainloop LOG file (I still cannot login to rainloop no matter what.
    (All plugins / packages are disabled) - domains have been added (but fail SMTP tests) - I have attemped short logins and without, changed the ports, adjusted the smtp settings but nothing works. I CANNOT login. (To even test my smtp).
  • I tried adding and but still no luck. Of course i configured the mail servers as the mail. domain.
  1. Why doesn’t Cyberpanel re-configure email to send through ports, or give us this flexibility? This should be an option on the panel

Edit, so i found the DOVECOT log files when i tried freshly installing that.

This is the error i get when i attempt to login:
auth-worker(7844): Error: sql ( + passwordhash) etc. info here.

So I tried creating a whole new account, with a new with a new password. And still SAME error. :frowning: