Email DNS Configuration

I had set up a small vps using cyberpanel, done configure the necessary setting include rdns.

unfortunately, when I send a test to mail-tester.com, I see this server.example.com, which I had no clue where to amend.
(I don’t remember I had configured such URL during my installation :thinking:)

Anyone can point me some direction?

screenshot here:

You can use this guide to change from server.example.com

Also read → Achieve 10/10 Email score with CyberPanel! - CyberPanel

thank for the direction,

when I try to issue ssl for my mail server, I receive this error message.

Cannot issue SSL. Error message: 0,283 Failed to obtain SSL for domain. [issueSSLForDomain]

Is there any additional step I require to take before I issue ssle for my mail server?

I searching around the forum, found one of your reply recommend to add this code:

wget -O - https://get.acme.sh | sh

After that I manage to add ssl for my mail server. I solve partially of the problem, but from mail-tester, I still see below error:

Your IP address 45.xx.xx.xx is associated with the domain server0.domain.asia.
Nevertheless your message appears to be sent from domain.asia.

You may want to publish a pointer (PTR type) DNS record with a value of
domain.asia or use server0.domain.asia as hostname in your mail software

Here are the tested values for this check:
IP: 45.xx.xx.xx
HELO: domain.asia
rDNS: server0.domain.asia

Basically my rnds is set in my vps control panel. I am no clue where should further troubleshoot?

Anyone can give me some direction? I believe I need to do some setting for PTR?

I solve the problem by change my rdns from server0.domain.asia to domain.asia.

Great, thanks.

Type your comment> @calvynlee said:

I solve the problem by change my rdns from server0.domain.asia to domain.asia.

May I ask how you can do that?

You do that with your HOSTING provider. if you’re using ie. LINODE you go to LINODE settings. :slight_smile: