Dovecot Not installed during the Installation

Hi Team, I’m facing difficulties with the new installation. Last week, when I installed the process went smoothly. But today when I tried, the installation completed with error. Yes. The Dovecot services were not installed during the installation. So there is no dovecot folder in the /etc folder to grab the dovecot.conf file. When I tried to install dovecot from the repository, the service runs, but it gives authentication error and Cant connect to the server error sometimes. Rainloop didn’t work. Outlook didn’t work. Postfix works fine. Please help me with the issue.

Server Specs:
Ram: 4GB
CPU: 4
Swap: 512MB
OS: Ubuntu 20.04.2 LTS GNU/Linux 5.4.0 x86_64)

Virtualization: OpenVZ
Hosting: A2 Unmanaged VPS.

Kindly do the needful.

I tried this - Email not working after CyberPanel Upgrade? - CyberPanel and some other guides but nothing worked. The thing is the conf file for dovecot is not created during the install. So I’m getting authentication error even if I install the dovecot manually.

same after clean installation on ubuntu 18.04 or 20.04

You guys must be choosing minimal installation, make sure you don’t choose minimal installation.

I have found the probleb, after install update-inetd, CP have installed sucsesfuly

Hi @usmannasir , Thanks for the reply. I have not chosen the minimal installation. I did a full installation.
For now, I’m hosting the emails on a different server. I’m trying the installation again and will let you know.


Type your comment> @WaReZoR said:

I have found the probleb, after install update-inetd, CP have installed sucsesfuly

thanks, it work.

quite weird since 1month ago, dovecot are exist in this version (2.1.1)

I faced the same problem in my VPS A2Hosting.
Runing these commands fix the problem, first prepare a fresh ubuntu 20.04 and then :

apt update
apt-get install curl nano update-inetd -y
ln -s /bin/sed /usr/bin/sed
sh <(curl || wget -O -

Maybe you have a look at this dovecot workaround. Maybe it fits your problem: