DNS Records for Sub-domain or 3rd level domain

Hello All,

I am trying to have separate email server from my webserver. I am currently having a 3rd level domain or sub domain were the website is developed. And I have installed the latest cyberpanel in a new VPS and added the subdomain (domain.tld.tld) as a website, but DNS records were not getting created for it.

Can anyone please help me out?

P.S. DNS records is getting created for main domain (site.tld) just not for 3rd or subdomain.


Hello @mano3032

Which server os is this ?

Are you using the lastest copy of cyberpanel ?

@josephgodwinke CentOS 7 and yes I am using latest version of cyberpanel

Is this a new installation ?

@josephgodwinke yes, this is a new installation

Server with a fresh install of Centos 7.x (Not recommended for new installs)


@josephgodwinke I have even tried with Ubuntu 22.04 LTS but having the same issue.

The most stable operating systems are Ubuntu 20.04 and AlmaLinux 8.3 - 8.4. Kindly use those versions meantime I will try recreate the issue on Ubuntu 22

@josephgodwinke same issue with CentOS 8 & Ubuntu 20.04. Will try AlmaLinux 8 64-bit and update.

Give an example of a domain ?

@josephgodwinke https://site1.globalreports.xyz

Try an upgrade and test again

Probably check this see it it helps Fixed Subdomain permissions issue on Centos7/8/Almalinux/Rocky

still not working. any more ideas?

How do you create this subdomain website. Kindly explain