DKIM Key Generation fails - Permission denied

While in the “DKIM MANAGER” panel I try to generate a key by selecting my website and clicking the “Generate Now” button.

I receive an error:
[Errno 13] Permission denied: ‘/usr/local/CyberCP/lib/python3.8/site-packages/tldextract/.suffix_cache/publicsuffix.org-tlds/de84b5ca2167d4c83e38fb162f2e8738.tldextract.json.lock’

I ssh into that folder and the lock file is being generated on “Generate Now”, they have the permissions of -rwxr-xr-x 1 root root.

It looks like this is a common problem recently but I haven’t found an answer anywhere.

Is this a more common problem with Python?

I played around with a lot of things trying to fix it so I don’t know exactly what fixed it. But I think running the cyberpanel upgrade script might have done it.
sh <(curl https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh)

Either that or running > opendkim-default-keygen

might have helped.

Hmmm, I don’t know how I fixed it, but now I go to the DKIM panel and it shows my keys.

I upgraded CyberPanel: h <(curl https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh)

and ran: opendkim-default-keygen

rebooted a few times. Sorry no idea what actually fixed it.

The solution is to grant permission to Cyberpanel.

chown -R cyberpanel:cyberpanel /usr/local/CyberCP/lib/python3.8/site-packages/tldextract/.suffix_cache/