Deployed Vue.js Front-End Not Working (But Works Locally)

Hello fellow developers,

I’m reaching out because I’m facing a puzzling issue with my deployed Vue.js front-end, and I’m hoping some of you might be able to lend a hand.

Here’s what’s going on:

I have a Laravel back-end and a Vue.js front-end for my application. Everything works perfectly fine when I run the app locally. However, after deploying it, I’ve noticed that only the back-end is functioning as expected. The Vue.js front-end seems to be having issues. When accessing the deployed application, the vue recaptcha don’t load as they should. Some features that work locally are not working on the deployed version. (Screenshot below)

Despite my efforts, I still can’t figure out why the deployed version is acting differently from the one on my computer. I’m hoping that some fresh eyes might be able to spot something I’ve missed or suggest steps I can take to diagnose the problem.

Login Local

Login Deployed

User Side Local

User Side Deployed

Admin Side Local

Admin Side Deployed

If any of you have encountered a similar situation or have suggestions for troubleshooting steps, I would greatly appreciate your input. Feel free to ask for more details if needed.

Thank you all in advance for your help!

Welcome @hello101 Happy you are here

What errors do you have in your browser console ?

currently our server is down

This is the console for admin

This is the console for user

I also commented the console log and email route, but still doesn’t reflect when I refreshes the page. When I change something in php I can see it right anyway.