Cyperpanel DNS ipv6 format

Hello,
I’d like to ask what the correct format is for ipv6 inputs in the AAAA records, because however I format the ipv6 address I get “Cannot add record. Error message: Data supplied is not accepted.”

Edit: the documentation doesn’t cover this.

Bug, needs fixing.

Thanks for noticing. Hope it will get fixed in the future. In ne meantime I can help myself with mysql. The SRV Record syntax also seems invalid bc the dot is not appended on the end. It only populated for me after fixing. And one bigger feature request would be an automated TSLA Record feature to enable DANE.

Still needs to be fixed

Still not fixed.

Type your comment> @chiareu said:

Still not fixed.

Not true. Both full and short IPv6 addresses (with double ::slight_smile: are saved successfully. I don’t have CP installed in any IPv6 capable server atm but last time I checked it wouldn’t automatically create the AAAA records.

What version you use?
I use Version 2.0 Build 3
Cannot add record. Error message: Data supplied is not accepted, following characters are not allowed in the input ` $ & ( ) [ ] { } ; : ‘ < >.