Cyberpanel small nuisances

I’m preparing to migration of my site of plesk/nginx to Cyberpanel/OLS. For last two weeks I was checking dozen of different configurations (Centos 7, Centos 8, Ubuntu 20.04) and comparing with niginx/Apache. I’ve decided to settle on Centos 8, but have noticed some repeatable issues:

  1. Redis server is not installed, despite checking this option in install script. It has to be installed manually
  2. Some PHP extensions are marked as not installed, while they are installed physically, like lsphp74-mcrypt, lsphp74-zip or lsphp74-pecl-redis
  3. Service status is showing ProFTPd service as stopped, while it is running
  4. Regardless of which option is enabled in OLS, brotli compression seems to not run
  5. It is probably my fault - I wanted to check Enterprise version, how is handling brotli. I’ve put wrong license key and whole configuration collapsed. Switch to enterprise failed, but OLS crashed and couldn’t be started again from panel. After starting from command line, configuration was corrupted and cache wasn’t working.
  6. Last point is very nimble, but it was noticed by some users in previous posts. After setting up LS cache plugin in Wordpress, first read is quite slow, while second is blazing fast. By saying quite slow I mean compared to pure OLS without cache plugin. If cache is warmed, then GTMetrix/Pingdom/Pagespeed is flying like crazy. This is biggest puzzle for me.
    I’m desperate to reach stable configuration, as all tests indicate consistent and better pagespeed results then nginx with rocket cache plugin.

Cheers, Voytech

re: #6 – I’m seeing this in Magento as well. The way to achieve this in Wordpress (same as with those that use Magento) is to warm the cache using a plugin like this:

I haven’t used it (or have anything to do with the plugin) but it operates the same as the Magento cache warmer. It reads your sitemap.xml file at whatever interval you set it via cron to load each page into the LiteSpeed cache so you’re site always performs fast since all static pages are cached. There may be other plugins and this one may be buggy, so test test test. You simply want the server to load each static page into the LiteSpeed cache on it’s own and keep it there for ‘X’ amount of time before refreshing it.

I’m also coming from Plesk/NGINX and I agree, the difference with LS is amazing.

Re: Ad 1 - yes, I’m 100% positive. I’ve already installed Cyberpanel more then 10 times and it happens on Centos 8 all the time. I’ve just installed Cyberpanel again and here is result of systemctl status redis:
Unit redis.service could not be found.
My procedure is following: dnf upgrade, kernel upgrade (currently on 5.7.7-1.el8.elrepo.x86_64), running Cyberpanel install script. Then upgrade MariaDB to 10.5 and install redis.
Not a big deal, but still.
Re: Ad 4 - I’m using external tools like
One more observation about performance. When using to stress test server I’m getting tons of “No request delivery notification has been received from LSAPI application, possible dead lock.” errors and response times around 20000ms. Once cache is enabled, errors are gone and response time settle on 150-200ms. Increasing PHP memory limit up to 1GB didn’t help.

Noticed the same problem with Redis and lsphpXX-redis not installed even when I have said yes to installing Redis on Ubuntu 18.04 and 20.04 as well.

Related thread: Redis php extension not shown in list — CyberPanel - WebHosting Control Panel for OpenLiteSpeed

I know it’s an old questoin, but if i came across it when i was researching I think it’d be valuable to answer each one.

I’m using the FREE version so…


  1. I have not had this problem, I installed everything manually and I’m not even connected to the cloud. - It just auto installs in the latest version. I did have to MANUALLY click INSTALL within Cyberpanel (it’s under SERVICES > APPLICATIONS?)

  2. ^ solved in CP

3. Re-install Cyberpanel- you’ve gone wrong somewhere.

Brotli Compression
4. It works flawlessly, mine is set to 6 in OLS and is functioning fine using the LSCACHE plugin (have to enable it in there manually or it just uses memcache for some reason)

5. Can’t answer

6. Perhaps you’re getting a bit of server load, what’s your RAM at? CPU load at? I found this issue when my ram was overloaded after having 10 sites running on 1GB (lol) so i upgraded my VPS.