Cyberpanel not pulling records from Cloudflare

@usmannasir Quick question:
Is my understanding correct that CP will pull existing records that were created in CF down to CP as well? Or is my understanding incorrect?

I’ve added a Global Token and get a green success message that "Records successfully fetched for domain, but don’t see any records reflected in CP.

I’ve disabled locally sync with CF and I only want CF records to be pulled by CP.

Ubuntu 22.04, I’ve checked to make sure port 53 is open everywhere. Also tried disabling the whole FW everywhere. Same issue.

Just to add:
Out of curiosity I’ve checked my other installation (not the VPS from above) that’s running 20.04 on Vultr and it works fine on this setup, but not the VPS that’s running 22.04. Both have the most current version of CP

Current Version:  2.3
Build:  4Current Commit:  d65b6b5bcd4e89ce1a0eeb74131f98093e85bb3a
Latest Version:  2.3
Latest Build:  4Latest Commit:  d65b6b5bcd4e89ce1a0eeb74131f98093e85bb3a

and OLS installed.

@josephgodwinke You wouldn’t happened to know how to reset or delte the CF/CP connection or sync via terminal command and re-add the connection to see if that fixes the issue?

Cause it does say it successfully fetch the records, but does not display the existing records I can see in CF

Do not know as of now, but last year it was only sent from cyberpanel → cloudflare, not the other way around.

There. Read the script to see what it does (you can even reproduce it manually).
Use invoke the script as:
./ -k API_KEY -e EMAIL -d “

It will use your cloudflare email and API key to pull the DNS records for the given and add them to the powerdns database that cyberpanel uses.

Please note that the script uses the default MySQL password generated by cyberpanel, if you have changed it you can either edit the file it read from or hardcode it on the script for the new password:

mysql_password=$(cat /etc/cyberpanel/mysqlPassword)

Thanks for the script (nice collection, BTW). I just tried it out after filling in line 3-5 of the .sh file and then executing the script with

/ -k myglobalAPIkey -e [email protected] -d ""

but get the following error:

./ line 15: jq: command not found

Any ideas what that is referring to?

Just to add:
CP does pull from CF on my other setup that is running 20.04. On my 22.04 (where it is not working) is also pulling something but does not display it.

install the package “jq”, its the tool to extract specific data from the json

Very weird indeed, in that case sadly I can’t help as I haven’t checked the latest versions

Thanks, didn’t know jq was a package. I tried it, but it didn’t solve the underlying issue. I’m just going to assume it’s a bug. CP tends to have a few bugs here and there.

Anyway, thanks for the help!

Yes unfortunately that is just to sync from CF into cyberpanel, needs to be run every time you wish to do it
Not a fix but just a workaround
No problem