Cyberpanel is can't be installed on Alibaba Cloud

Hi,

OLS or Enterprise:
OLS

Installing from official server or mirror server:
Yes

Replace JS/CSS files to JS Deliver:
yes

Install Memcached extension for PHP?
no

Install LiteSpeed Memcached?
no

Install Memcached?
no

Install Redis extension for PHP?
yes

Install Redis?
yes

Problem:

I can’t install Cyberpanel on Alibaba cloud. I have 2CPU and 4GB Ram server.
Operation Systems I tried to install Cyberpanel: Centos 7.6 - Ubuntu 18.04

[12-08-36-Wed-Jul-2019] #########################################################################

[12-08-36-Wed-Jul-2019] Trying to install tldextract, trying again, try number: 20

[12-08-36-Wed-Jul-2019] #########################################################################

Collecting bcrypt
Downloading http://mirrors.cloud.aliyuncs.com/pypi/packages/50/d8/95f7cb04344033bf9d1a12c5a7969a15999b6a710fbe1969c517333d9a62/bcrypt-3.1.6-cp27-cp27mu-manylinux1_x86_64.whl (59kB)
100% |████████████████████████████████| 61kB 309kB/s
Collecting cffi>=1.1 (from bcrypt)
Downloading http://mirrors.cloud.aliyuncs.com/pypi/packages/14/dd/3e7a1e1280e7d767bd3fa15791759c91ec19058ebe31217fe66f3e9a8c49/cffi-1.11.5-cp27-cp27mu-manylinux1_x86_64.whl (407kB)
100% |████████████████████████████████| 409kB 60.7MB/s
Requirement already satisfied (use --upgrade to upgrade): six>=1.4.1 in /usr/lib64/python2.7/site-packages (from bcrypt)
Collecting pycparser (from cffi>=1.1->bcrypt)
Downloading http://mirrors.cloud.aliyuncs.com/pypi/packages/68/9e/49196946aee219aead1290e00d1e7fdeab8567783e83e1b9ab5585e6206a/pycparser-2.19.tar.gz (158kB)
100% |████████████████████████████████| 163kB 64.9MB/s
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File “”, line 1, in
File “/tmp/pip-build-ZXlMpO/pycparser/setup.py”, line 65, in
cmdclass={‘install’: install, ‘sdist’: sdist},
File “/usr/lib64/python2.7/distutils/core.py”, line 112, in setup
_setup_distribution = dist = klass(attrs)
File “/usr/lib/python2.7/site-packages/setuptools/dist.py”, line 269, in init
_Distribution.init(self,attrs)
File “/usr/lib64/python2.7/distutils/dist.py”, line 287, in init
self.finalize_options()
File “/usr/lib/python2.7/site-packages/setuptools/dist.py”, line 302, in finalize_options
ep.load()(self, ep.name, value)
File “/usr/lib/python2.7/site-packages/pkg_resources/init.py”, line 2341, in load
return self.resolve()
File “/usr/lib/python2.7/site-packages/pkg_resources/init.py”, line 2351, in resolve
raise ImportError(str(exc))
ImportError: ‘module’ object has no attribute ‘check_specifier’

----------------------------------------

Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-build-ZXlMpO/pycparser/
You are using pip version 8.1.2, however version 19.2.1 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.

Also below error on Ubuntu 18.04:

DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7.
Looking in indexes: https://mirrors.163.com/pypi/simple
Collecting MySQL-python
WARNING: Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by ‘SSLError(SSLError(1, u’[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:727)’),)’: /pypi/simple/mysql-python/
WARNING: Retrying (Retry(total=3, connect=None, read=None, redirect=None, status=None)) after connection broken by ‘SSLError(SSLError(1, u’[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:727)’),)’: /pypi/simple/mysql-python/
Downloading https://mirrors.163.com/pypi/packages/a5/e9/51b544da85a36a68debe7a7091f068d802fc515a3a202652828c73453cad/MySQL-python-1.2.5.zip (108kB)
|████████████████████████████████| 112kB 80kB/s
Building wheels for collected packages: MySQL-python
Building wheel for MySQL-python (setup.py) … done
Stored in directory: /root/.cache/pip/wheels/26/88/fb/8a32c6464aa18e9a0fde2c7648c69bef6aeedffea46594fe42
Successfully built MySQL-python
Installing collected packages: MySQL-python
Successfully installed MySQL-python-1.2.5
WARNING: You are using pip version 19.1.1, however version 19.2.1 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.

Creating config file /usr/local/lsws/lsphp71/etc/php/7.1/mods-available/pspell.ini with new version
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module pspell ini file doesn’t exist under /etc/php/7.2/mods-available
Setting up lsphp71-recode (7.1.30-12+bionic) …

Creating config file /usr/local/lsws/lsphp71/etc/php/7.1/mods-available/recode.ini with new version
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module recode ini file doesn’t exist under /etc/php/7.2/mods-available
Setting up lsphp71-json (7.1.30-12+bionic) …

Creating config file /usr/local/lsws/lsphp71/etc/php/7.1/mods-available/json.ini with new version
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module json ini file doesn’t exist under /etc/php/7.2/mods-available
Setting up lsphp73-intl (7.3.7-13+bionic) …

Creating config file /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/intl.ini with new version
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module intl ini file doesn’t exist under /etc/php/7.2/mods-available
Setting up lsphp71-intl (7.1.30-12+bionic) …

Creating config file /usr/local/lsws/lsphp71/etc/php/7.1/mods-available/intl.ini with new version
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module intl ini file doesn’t exist under /etc/php/7.2/mods-available
Setting up lsphp73-ldap (7.3.7-13+bionic) …

Creating config file /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/ldap.ini with new version
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module ldap ini file doesn’t exist under /etc/php/7.2/mods-available
Setting up lsphp71-dev (7.1.30-12+bionic) …
update-alternatives: renaming php-config link from /usr/local/lsws/lsphp72/bin/php-config to /usr/local/lsws/lsphp71/bin/php-config
update-alternatives: renaming phpize link from /usr/local/lsws/lsphp72/bin/phpize to /usr/local/lsws/lsphp71/bin/phpize
Setting up lsphp71-sqlite3 (7.1.30-12+bionic) …

Creating config file /usr/local/lsws/lsphp71/etc/php/7.1/mods-available/sqlite3.ini with new version
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module sqlite3 ini file doesn’t exist under /etc/php/7.2/mods-available

Creating config file /usr/local/lsws/lsphp71/etc/php/7.1/mods-available/pdo_sqlite.ini with new version
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module pdo_sqlite ini file doesn’t exist under /etc/php/7.2/mods-available
Setting up php7.2-readline (7.2.19-0ubuntu0.18.04.1) …

Creating config file /etc/php/7.2/mods-available/readline.ini with new version
Setting up lsphp73-sqlite3 (7.3.7-13+bionic) …

Creating config file /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/sqlite3.ini with new version
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module sqlite3 ini file doesn’t exist under /etc/php/7.2/mods-available

Creating config file /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/pdo_sqlite.ini with new version
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module pdo_sqlite ini file doesn’t exist under /etc/php/7.2/mods-available
Setting up lsphp73-mysql (7.3.7-13+bionic) …

Creating config file /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/mysqli.ini with new version
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module mysqli ini file doesn’t exist under /etc/php/7.2/mods-available

Creating config file /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/pdo_mysql.ini with new version
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module pdo_mysql ini file doesn’t exist under /etc/php/7.2/mods-available
Setting up lsphp70-imap (7.0.33-12+bionic) …

Creating config file /usr/local/lsws/lsphp70/etc/php/7.0/mods-available/imap.ini with new version
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module imap ini file doesn’t exist under /etc/php/7.2/mods-available
Setting up lsphp70-dev (7.0.33-12+bionic) …
update-alternatives: renaming php-config link from /usr/local/lsws/lsphp71/bin/php-config to /usr/local/lsws/lsphp70/bin/php-config
update-alternatives: renaming phpize link from /usr/local/lsws/lsphp71/bin/phpize to /usr/local/lsws/lsphp70/bin/phpize
Setting up php7.2-json (7.2.19-0ubuntu0.18.04.1) …

Creating config file /etc/php/7.2/mods-available/json.ini with new version
Setting up lsphp71-imap (7.1.30-12+bionic) …

Creating config file /usr/local/lsws/lsphp71/etc/php/7.1/mods-available/imap.ini with new version
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module imap ini file doesn’t exist under /etc/php/7.2/mods-available
Setting up aspell (0.60.7~20110707-4) …
Setting up lsphp73-imap (7.3.7-13+bionic) …

Creating config file /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/imap.ini with new version
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module ALL ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module imap ini file doesn’t exist under /etc/php/7.2/mods-available
Setting up hunspell-en-us (1:2017.08.24) …
Setting up php7.2-opcache (7.2.19-0ubuntu0.18.04.1) …

Creating config file /etc/php/7.2/mods-available/opcache.ini with new version
Setting up libenchant1c2a:amd64 (1.6.0-11.1) …
Setting up php-readline (1:7.2+60ubuntu1) …
Setting up php7.2-xml (7.2.19-0ubuntu0.18.04.1) …

Creating config file /etc/php/7.2/mods-available/dom.ini with new version

Creating config file /etc/php/7.2/mods-available/simplexml.ini with new version

Creating config file /etc/php/7.2/mods-available/wddx.ini with new version

Creating config file /etc/php/7.2/mods-available/xml.ini with new version

Creating config file /etc/php/7.2/mods-available/xmlreader.ini with new version

Creating config file /etc/php/7.2/mods-available/xmlwriter.ini with new version

Creating config file /etc/php/7.2/mods-available/xsl.ini with new version
Setting up lsphp70 (7.0.33-12+bionic) …

Creating config file /usr/local/lsws/lsphp70/etc/php/7.0/litespeed/php.ini with new version
Setting up lsphp73 (7.3.7-13+bionic) …

Creating config file /usr/local/lsws/lsphp73/etc/php/7.3/litespeed/php.ini with new version
Setting up php-xml (1:7.2+60ubuntu1) …
Setting up php7.2-cli (7.2.19-0ubuntu0.18.04.1) …
update-alternatives: using /usr/bin/php7.2 to provide /usr/bin/php (php) in auto mode
update-alternatives: using /usr/bin/phar7.2 to provide /usr/bin/phar (phar) in auto mode
update-alternatives: using /usr/bin/phar.phar7.2 to provide /usr/bin/phar.phar (phar.phar) in auto mode

Creating config file /etc/php/7.2/cli/php.ini with new version
Setting up aspell-en (2017.08.24-0-0.1) …
Setting up php-pear (1:1.10.5+submodules+notgz-1ubuntu1.18.04.1) …
Setting up enchant (1.6.0-11.1) …
Setting up lsphp72 (7.2.20-13+bionic) …

Creating config file /usr/local/lsws/lsphp72/etc/php/7.2/litespeed/php.ini with new version
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module 7.2 ini file doesn’t exist under /etc/php/7.2/mods-available
WARNING: Module litespeed ini file doesn’t exist under /etc/php/7.2/mods-available

Sorry for flooding. I’m adding logs continuously.


The following NEW packages will be installed:
python-gpg
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 149 kB of archives.
After this operation, 1,038 kB of additional disk space will be used.
Get:1 Index of /ubuntu/ bionic-updates/universe amd64 python-gpg amd64 1.10.0-1ubuntu2 [149 kB]
Fetched 149 kB in 3s (49.1 kB/s)
Selecting previously unselected package python-gpg.
(Reading database … 117771 files and directories currently installed.)
Preparing to unpack …/python-gpg_1.10.0-1ubuntu2_amd64.deb …
Unpacking python-gpg (1.10.0-1ubuntu2) …
Setting up python-gpg (1.10.0-1ubuntu2) …
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package python-gpgme is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘python-gpgme’ has no installation candidate

[12-53-25-Wed-Jul-2019] #########################################################################

[12-53-25-Wed-Jul-2019] Error #100 installing:python-gpgme. This may not be an issue but may affect installation of something later

[12-53-25-Wed-Jul-2019] #########################################################################

DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7.
Looking in indexes: Simple Index
Collecting virtualenv
WARNING: Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by ‘SSLError(SSLError(1, u’[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:727)’),)’: /pypi/simple/virtualenv/
WARNING: Retrying (Retry(total=3, connect=None, read=None, redirect=None, status=None)) after connection broken by ‘SSLError(SSLError(1, u’[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:727)’),)’: /pypi/simple/virtualenv/
Downloading https://mirrors.163.com/pypi/packages/db/9e/df208b2baad146fe3fbe750eacadd6e49bcf2f2c3c1117b7192a7b28aec4/virtualenv-16.7.2-py2.py3-none-any.whl (3.3MB)
|████████████████████████████████| 3.3MB 1.3MB/s
Installing collected packages: virtualenv
Successfully installed virtualenv-16.7.2
WARNING: You are using pip version 19.1.1, however version 19.2.1 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.

[12-53-39-Wed-Jul-2019] #########################################################################

[12-53-39-Wed-Jul-2019] virtualenv installed successfully!

[12-53-39-Wed-Jul-2019] #########################################################################

Hi,

You are using Ubuntu ?

Could you please try CentOS ? just for test.

Best regards,

Hi,

Please try again , I fixed both centos and ubuntu in alibaba cloud , tested on a ECS i just bought in Frankfurt.

let me know how it goes.

Best regards,

@qtwrk Thank you very much for your help. I think it is fixed now :smile:

###############################################################
CyberPanel Successfully Installed

            Current Disk usage : 3/40GB (10%)                        
                                                               
            Current RAM  usage : 283/3789MB (7.47%)

###############################################################

Everything looks fine :smile:
King regards.

Hello @qtwrk

When I upgrade CyberPanel from 1.8.8 to 1.8.9 on Alibaba cloud, the same issue occurred.

ERROR: Could not find a version that satisfies the requirement IPy==0.75 (from -r /usr/local/CyberCP/requirments.txt (line 27)) (from versions: none)
ERROR: No matching distribution found for IPy==0.75 (from -r /usr/local/CyberCP/requirments.txt (line 27))

[04-30-42-Wed-Aug-2019] #########################################################################

[04-30-42-Wed-Aug-2019] CyberPanel requirements failed, trying again, try number: 3

[04-30-42-Wed-Aug-2019] #########################################################################

[04-30-42-Wed-Aug-2019] #########################################################################

[04-30-42-Wed-Aug-2019] CyberPanel requirements failed.

[04-30-42-Wed-Aug-2019] #########################################################################

I can’t access to Cyberpanel. (500 error). I have a snapshot from 1.8.8, so I saved my server. But I can’t upgrade it.

Thank you!

Hi,

Could you please provide full log ? from python upgrade.py until this last line.

Of course, here is the full logs: @qtwrk

[05-44-05-Fri-Aug-2019] #########################################################################

[05-44-05-Fri-Aug-2019] remove yum-plugin-priorities successful.

[05-44-05-Fri-Aug-2019] #########################################################################

[05-44-05-Fri-Aug-2019] #########################################################################

[05-44-05-Fri-Aug-2019] stop lscpd successful.

[05-44-05-Fri-Aug-2019] #########################################################################

cyberpanel için kabuk değiştiriliyor.
chsh: Warning: “/bin/false” is not listed in /etc/shells.
chsh: Shell not changed.
adduser: user ‘docker’ already exists

[05-44-05-Fri-Aug-2019] #########################################################################

[05-44-05-Fri-Aug-2019] adduser docker failed, trying again, try number: 1

[05-44-05-Fri-Aug-2019] #########################################################################

adduser: user ‘docker’ already exists

[05-44-05-Fri-Aug-2019] #########################################################################

[05-44-05-Fri-Aug-2019] adduser docker failed, trying again, try number: 2

[05-44-05-Fri-Aug-2019] #########################################################################

adduser: user ‘docker’ already exists

[05-44-05-Fri-Aug-2019] #########################################################################

[05-44-05-Fri-Aug-2019] adduser docker failed, trying again, try number: 3

[05-44-05-Fri-Aug-2019] #########################################################################

[05-44-05-Fri-Aug-2019] #########################################################################

[05-44-05-Fri-Aug-2019] adduser docker failed.

[05-44-05-Fri-Aug-2019] #########################################################################

groupadd: group ‘docker’ already exists

[05-44-05-Fri-Aug-2019] #########################################################################

[05-44-05-Fri-Aug-2019] adduser docker failed, trying again, try number: 1

[05-44-05-Fri-Aug-2019] #########################################################################

groupadd: group ‘docker’ already exists

[05-44-05-Fri-Aug-2019] #########################################################################

[05-44-05-Fri-Aug-2019] adduser docker failed, trying again, try number: 2

[05-44-05-Fri-Aug-2019] #########################################################################

groupadd: group ‘docker’ already exists

[05-44-05-Fri-Aug-2019] #########################################################################

[05-44-05-Fri-Aug-2019] adduser docker failed, trying again, try number: 3

[05-44-05-Fri-Aug-2019] #########################################################################

[05-44-05-Fri-Aug-2019] #########################################################################

[05-44-05-Fri-Aug-2019] adduser docker failed.

[05-44-05-Fri-Aug-2019] #########################################################################

[05-44-05-Fri-Aug-2019] #########################################################################

[05-44-05-Fri-Aug-2019] adduser docker successful.

[05-44-05-Fri-Aug-2019] #########################################################################

[05-44-05-Fri-Aug-2019] #########################################################################

[05-44-05-Fri-Aug-2019] adduser docker successful.

[05-44-05-Fri-Aug-2019] #########################################################################

–2019-08-16 17:44:05-- https://cyberpanel.sh/composer.sh
cyberpanel.sh (cyberpanel.sh) çözümleniyor… 89.208.248.38
cyberpanel.sh (cyberpanel.sh)[89.208.248.38]:443 bağlanılıyor… bağlantı kuruldu.
HTTP isteği gönderildi, yanıt bekleniyor… 200 OK
Uzunluk: 190 [application/x-sh]
Saving to: ‘composer.sh’

100%[==================================================================================================================================================================>] 190 --.-K/s in 0s

2019-08-16 17:44:07 (28,6 MB/s) - ‘composer.sh’ saved [190/190]

PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/local/lsws/lsphp71/lib64/php/modules/timezonedb.so’ - /usr/local/lsws/lsphp71/lib64/php/modules/timezonedb.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/local/lsws/lsphp71/lib64/php/modules/timezonedb.so’ - /usr/local/lsws/lsphp71/lib64/php/modules/timezonedb.so: cannot open shared object file: No such file or directory in Unknown on line 0
All settings correct for using Composer
Downloading…

Composer (version 1.9.0) successfully installed to: /usr/local/composer.phar
Use it: php composer.phar

PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/local/lsws/lsphp71/lib64/php/modules/timezonedb.so’ - /usr/local/lsws/lsphp71/lib64/php/modules/timezonedb.so: cannot open shared object file: No such file or directory in Unknown on line 0
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at Release process - pip documentation v22.0.dev0
Looking in indexes: Simple Index
Requirement already satisfied: pydns in /usr/lib64/python2.7/site-packages (2.3.6)
WARNING: You are using pip version 19.2.1, however version 19.2.2 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.

[05-44-16-Fri-Aug-2019] #########################################################################

[05-44-16-Fri-Aug-2019] Install PyDNS successful.

[05-44-16-Fri-Aug-2019] #########################################################################

–2019-08-16 17:44:16-- https://cyberpanel.net/CyberPanel.1.8.9.tar.gz
cyberpanel.net (cyberpanel.net) çözümleniyor… 104.27.163.149, 104.27.162.149, 2606:4700:30::681b:a295, …
cyberpanel.net (cyberpanel.net)[104.27.163.149]:443 bağlanılıyor… bağlantı kuruldu.
HTTP isteği gönderildi, yanıt bekleniyor… 301 Moved Permanently
Yer: https://cyberpanel.sh/CyberPanel.1.8.9.tar.gz [izleyen]
–2019-08-16 17:44:16-- https://cyberpanel.sh/CyberPanel.1.8.9.tar.gz
cyberpanel.sh (cyberpanel.sh) çözümleniyor… 89.208.248.38
cyberpanel.sh (cyberpanel.sh)[89.208.248.38]:443 bağlanılıyor… bağlantı kuruldu.
HTTP isteği gönderildi, yanıt bekleniyor… 200 OK
Uzunluk: 106654096 (102M) [application/gzip]
Saving to: ‘CyberPanel.1.8.9.tar.gz’

100%[==================================================================================================================================================================>] 106.654.096 9,95MB/s in 11s

2019-08-16 17:44:27 (9,33 MB/s) - ‘CyberPanel.1.8.9.tar.gz’ saved [106654096/106654096]

[05-44-27-Fri-Aug-2019] #########################################################################

[05-44-27-Fri-Aug-2019] Download latest version successful.

[05-44-27-Fri-Aug-2019] #########################################################################

[05-44-27-Fri-Aug-2019] #########################################################################

[05-44-27-Fri-Aug-2019] Backing up settings file.

[05-44-27-Fri-Aug-2019] #########################################################################

[05-44-27-Fri-Aug-2019] #########################################################################

[05-44-27-Fri-Aug-2019] Settings file backed up.

[05-44-27-Fri-Aug-2019] #########################################################################

[05-44-31-Fri-Aug-2019] #########################################################################

[05-44-31-Fri-Aug-2019] Extract latest version successful.

[05-44-31-Fri-Aug-2019] #########################################################################

[05-44-31-Fri-Aug-2019] #########################################################################

[05-44-31-Fri-Aug-2019] Restoring settings file!

[05-44-31-Fri-Aug-2019] #########################################################################

[05-44-31-Fri-Aug-2019] #########################################################################

[05-44-31-Fri-Aug-2019] Settings file restored!

[05-44-31-Fri-Aug-2019] #########################################################################

[05-44-31-Fri-Aug-2019] #########################################################################

[05-44-31-Fri-Aug-2019] Remove old static content successful.

[05-44-31-Fri-Aug-2019] #########################################################################

PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/local/lsws/lsphp70/lib64/php/modules/timezonedb.so’ - /usr/local/lsws/lsphp70/lib64/php/modules/timezonedb.so: cannot open shared object file: No such file or directory in Unknown on line 0
Do not run Composer as root/super user! See How do I install untrusted packages safely? Is it safe to run Composer as superuser or root? - Composer for details
Installing phpmyadmin/phpmyadmin (4.9.0.1)

  • Installing phpmyadmin/phpmyadmin (4.9.0.1): Loading from cache
    Created project in /usr/local/CyberCP/public/phpmyadmin
    Loading composer repositories with package information
    Installing dependencies (including require-dev) from lock file
    Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
    Package operations: 49 installs, 0 updates, 0 removals
  • Installing bacon/bacon-qr-code (1.0.3): Loading from cache
  • Installing google/recaptcha (1.2.2): Loading from cache
  • Installing symfony/expression-language (v2.8.50): Loading from cache
  • Installing phpmyadmin/motranslator (4.0): Loading from cache
  • Installing phpmyadmin/shapefile (2.1): Loading from cache
  • Installing symfony/polyfill-mbstring (v1.11.0): Loading from cache
  • Installing phpmyadmin/sql-parser (4.3.2): Loading from cache
  • Installing phpseclib/phpseclib (2.0.17): Loading from cache
  • Installing symfony/polyfill-util (v1.11.0): Loading from cache
  • Installing symfony/polyfill-php56 (v1.11.0): Loading from cache
  • Installing paragonie/random_compat (v2.0.18): Loading from cache
  • Installing paragonie/constant_time_encoding (v1.0.4): Loading from cache
  • Installing pragmarx/google2fa (v3.0.3): Loading from cache
  • Installing psr/container (1.0.0): Loading from cache
  • Installing samyoul/u2f-php-server (v1.1.4): Loading from cache
  • Installing tecnickcom/tcpdf (6.2.26): Loading from cache
  • Installing symfony/polyfill-ctype (v1.11.0): Loading from cache
  • Installing twig/twig (v1.42.1): Loading from cache
  • Installing twig/extensions (v1.5.4): Loading from cache
  • Installing psr/log (1.1.0): Loading from cache
  • Installing symfony/debug (v2.8.50): Loading from cache
  • Installing symfony/console (v2.8.50): Loading from cache
  • Installing symfony/process (v2.8.50): Loading from cache
  • Installing gitonomy/gitlib (v1.0.4): Loading from cache
  • Installing codacy/coverage (1.4.2): Loading from cache
  • Installing phpdocumentor/reflection-common (1.0.1): Loading from cache
  • Installing phpdocumentor/type-resolver (0.3.0): Loading from cache
  • Installing squizlabs/php_codesniffer (3.4.2): Loading from cache
  • Installing phpmyadmin/coding-standard (0.3): Loading from cache
  • Installing sebastian/recursion-context (1.0.5): Loading from cache
  • Installing sebastian/exporter (1.2.2): Loading from cache
  • Installing sebastian/diff (1.4.3): Loading from cache
  • Installing sebastian/comparator (1.2.4): Loading from cache
  • Installing webmozart/assert (1.4.0): Loading from cache
  • Installing phpdocumentor/reflection-docblock (3.2.2): Loading from cache
  • Installing doctrine/instantiator (1.0.5): Loading from cache
  • Installing phpspec/prophecy (1.8.0): Loading from cache
  • Installing sebastian/version (1.0.6): Loading from cache
  • Installing sebastian/environment (1.3.8): Loading from cache
  • Installing phpunit/php-token-stream (1.4.12): Loading from cache
  • Installing phpunit/php-text-template (1.2.1): Loading from cache
  • Installing phpunit/php-file-iterator (1.4.5): Loading from cache
  • Installing phpunit/php-code-coverage (2.2.4): Loading from cache
  • Installing phpunit/php-timer (1.0.9): Loading from cache
  • Installing phpunit/phpunit-mock-objects (2.3.8): Loading from cache
  • Installing symfony/yaml (v2.8.50): Loading from cache
  • Installing sebastian/global-state (1.1.1): Loading from cache
  • Installing phpunit/phpunit (4.8.36): Loading from cache
  • Installing phpunit/phpunit-selenium (1.4.2): Loading from cache
    phpmyadmin/phpmyadmin suggests installing ext-opcache (Better performance)
    phpmyadmin/phpmyadmin suggests installing ext-gd2 (For image transformations)
    phpmyadmin/shapefile suggests installing ext-dbase (For dbf files parsing)
    phpseclib/phpseclib suggests installing ext-libsodium (SSH2/SFTP can make use of some algorithms provided by the libsodium-php extension.)
    paragonie/random_compat suggests installing ext-libsodium (Provides a modern crypto API that can be used to generate random bytes.)
    twig/extensions suggests installing symfony/translation (Allow the time_diff output to be translated)
    symfony/console suggests installing psr/log-implementation (For using the console logger)
    symfony/console suggests installing symfony/event-dispatcher
    phpunit/php-code-coverage suggests installing ext-xdebug (>=2.2.1)
    sebastian/global-state suggests installing ext-uopz (*)
    phpunit/phpunit suggests installing phpunit/php-invoker (~1.1)
    Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested.
    Generating autoload files

[05-44-51-Fri-Aug-2019] #########################################################################

[05-44-51-Fri-Aug-2019] [Errno 2] No such file or directory: ‘/usr/local/CyberCP/public/rainloop/rainloop/v/1.12.1/include.php’ [downoad_and_install_raindloop]

[05-44-51-Fri-Aug-2019] #########################################################################

DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at Release process - pip documentation v22.0.dev0
Looking in indexes: Simple Index
Requirement already satisfied: tldextract in /usr/lib64/python2.7/site-packages (2.2.1)
Requirement already satisfied: requests-file>=1.4 in /usr/lib64/python2.7/site-packages (from tldextract) (1.4.3)
Requirement already satisfied: idna in /usr/lib64/python2.7/site-packages (from tldextract) (2.6)
Requirement already satisfied: setuptools in /usr/lib64/python2.7/site-packages (from tldextract) (40.8.0)
Requirement already satisfied: requests>=2.1.0 in /usr/lib64/python2.7/site-packages (from tldextract) (2.18.4)
Requirement already satisfied: six in /usr/lib64/python2.7/site-packages (from requests-file>=1.4->tldextract) (1.12.0)
Requirement already satisfied: urllib3<1.23,>=1.21.1 in /usr/lib64/python2.7/site-packages (from requests>=2.1.0->tldextract) (1.22)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/lib/python2.7/site-packages (from requests>=2.1.0->tldextract) (3.0.4)
Requirement already satisfied: certifi>=2017.4.17 in /usr/lib/python2.7/site-packages (from requests>=2.1.0->tldextract) (2019.6.16)
WARNING: You are using pip version 19.2.1, however version 19.2.2 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.

[05-44-52-Fri-Aug-2019] #########################################################################

[05-44-52-Fri-Aug-2019] Install tldextract successful.

[05-44-52-Fri-Aug-2019] #########################################################################

DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at Release process - pip documentation v22.0.dev0
Looking in indexes: Simple Index
Requirement already satisfied: bcrypt in /usr/lib64/python2.7/site-packages (3.1.7)
Requirement already satisfied: cffi>=1.1 in /usr/lib64/python2.7/site-packages (from bcrypt) (1.12.3)
Requirement already satisfied: six>=1.4.1 in /usr/lib64/python2.7/site-packages (from bcrypt) (1.12.0)
Requirement already satisfied: pycparser in /usr/lib64/python2.7/site-packages (from cffi>=1.1->bcrypt) (2.19)
WARNING: You are using pip version 19.2.1, however version 19.2.2 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.

[05-44-52-Fri-Aug-2019] #########################################################################

[05-44-52-Fri-Aug-2019] Install tldextract successful.

[05-44-52-Fri-Aug-2019] #########################################################################

[05-44-53-Fri-Aug-2019] #########################################################################

[05-44-53-Fri-Aug-2019] Setting up virtual environment for CyberPanel.

[05-44-53-Fri-Aug-2019] #########################################################################

Yüklü eklentiler: fastestmirror
Loading mirror speeds from cached hostfile
base | 3.6 kB 00:00:00
dovecot-2.3-latest | 2.9 kB 00:00:00
epel | 5.3 kB 00:00:00
extras | 3.4 kB 00:00:00
litespeed-mirror | 3.6 kB 00:00:00
litespeed-update-mirror | 3.6 kB 00:00:00
mariadb | 2.9 kB 00:00:00
powerdns-auth-42 | 2.9 kB 00:00:00
updates | 3.4 kB 00:00:00
(1/3): litespeed-update-mirror/primary_db | 99 kB 00:00:01
(2/3): epel/x86_64/updateinfo | 992 kB 00:00:04
(3/3): epel/x86_64/primary_db | 6.8 MB 00:00:10
Package libattr-devel-2.4.46-13.el7.x86_64 already installed and latest version
Package xz-devel-5.2.2-1.el7.x86_64 already installed and latest version
Package gpgme-devel-1.3.2-5.el7.x86_64 already installed and latest version
Package 1:mariadb-devel-5.5.60-1.el7_5.x86_64 is obsoleted by MariaDB-devel-10.1.41-1.el7.centos.x86_64 which is already installed
Package libcurl-devel-7.29.0-51.el7_6.3.x86_64 already installed and latest version
Yapılacak birşey yok

[05-45-11-Fri-Aug-2019] #########################################################################

[05-45-11-Fri-Aug-2019] VirtualEnv Pre-reqs successful.

[05-45-11-Fri-Aug-2019] #########################################################################

Yüklü eklentiler: fastestmirror
Loading mirror speeds from cached hostfile
Package libattr-devel-2.4.46-13.el7.x86_64 already installed and latest version
Package xz-devel-5.2.2-1.el7.x86_64 already installed and latest version
Package gpgme-devel-1.3.2-5.el7.x86_64 already installed and latest version
Package libcurl-devel-7.29.0-51.el7_6.3.x86_64 already installed and latest version
Yapılacak birşey yok

[05-45-12-Fri-Aug-2019] #########################################################################

[05-45-12-Fri-Aug-2019] VirtualEnv Pre-reqs successful.

[05-45-12-Fri-Aug-2019] #########################################################################

DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at Release process - pip documentation v22.0.dev0
Looking in indexes: Simple Index
Requirement already satisfied: virtualenv in /usr/lib64/python2.7/site-packages (16.7.2)
WARNING: You are using pip version 19.2.1, however version 19.2.2 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.

[05-45-12-Fri-Aug-2019] #########################################################################

[05-45-12-Fri-Aug-2019] VirtualEnv Install successful.

[05-45-12-Fri-Aug-2019] #########################################################################

No LICENSE.txt / LICENSE found in source
New python executable in /usr/local/CyberCP/bin/python2
Also creating executable in /usr/local/CyberCP/bin/python
Please make sure you remove any previous custom paths from your /root/.pydistutils.cfg file.
Installing setuptools, pip, wheel…
done.

[05-45-25-Fri-Aug-2019] #########################################################################

[05-45-25-Fri-Aug-2019] Setting up VirtualEnv [One] successful.

[05-45-25-Fri-Aug-2019] #########################################################################

No LICENSE.txt / LICENSE found in source
New python executable in /usr/local/CyberCP/bin/python2
Not overwriting existing python script /usr/local/CyberCP/bin/python (you must use /usr/local/CyberCP/bin/python2)
Please make sure you remove any previous custom paths from your /root/.pydistutils.cfg file.
Installing setuptools, pip, wheel…
done.
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at Release process - pip documentation v22.0.dev0
Looking in indexes: Simple Index
Collecting acme==0.21.1 (from -r /usr/local/CyberCP/requirments.txt (line 1))
Using cached https://mirrors.aliyun.com/pypi/packages/d8/83/d37e3598e8aff2e52d6e1b49aaae6cab548ca62595a4634c459c808b4557/acme-0.21.1-py2.py3-none-any.whl
Collecting asn1crypto==0.24.0 (from -r /usr/local/CyberCP/requirments.txt (line 2))
Using cached https://mirrors.aliyun.com/pypi/packages/ea/cd/35485615f45f30a510576f1a56d1e0a7ad7bd8ab5ed7cdc600ef7cd06222/asn1crypto-0.24.0-py2.py3-none-any.whl
Collecting Babel==0.9.6 (from -r /usr/local/CyberCP/requirments.txt (line 3))
Using cached https://mirrors.aliyun.com/pypi/packages/47/d8/84943abdffcc0f910327a08651e857e682efcda80e6650b1aa93679d5f60/Babel-0.9.6.tar.gz
Collecting bcrypt==3.1.7 (from -r /usr/local/CyberCP/requirments.txt (line 4))
Using cached https://mirrors.aliyun.com/pypi/packages/ad/36/9a0227d048e98409f012570f7bef8a8c2373b9c9c5dfbf82963cbae05ede/bcrypt-3.1.7-cp27-cp27mu-manylinux1_x86_64.whl
Collecting backports.ssl-match-hostname==3.5.0.1 (from -r /usr/local/CyberCP/requirments.txt (line 5))
Using cached https://mirrors.aliyun.com/pypi/packages/76/21/2dc61178a2038a5cb35d14b61467c6ac632791ed05131dda72c20e7b9e23/backports.ssl_match_hostname-3.5.0.1.tar.gz
Collecting boto3==1.9.64 (from -r /usr/local/CyberCP/requirments.txt (line 6))
Using cached https://mirrors.aliyun.com/pypi/packages/5c/3a/da62fd31ae6154fe32485f067c4ef9a3dc65880fee9d2b189a1d6c17def8/boto3-1.9.64-py2.py3-none-any.whl
Collecting botocore==1.12.64 (from -r /usr/local/CyberCP/requirments.txt (line 7))
Using cached https://mirrors.aliyun.com/pypi/packages/98/8b/490e56b674f9a4cc750ae3588dcf300a57b84f7d1f80daf0b21b3e4f1d1f/botocore-1.12.64-py2.py3-none-any.whl
Collecting certbot==0.21.1 (from -r /usr/local/CyberCP/requirments.txt (line 8))
Using cached https://mirrors.aliyun.com/pypi/packages/47/16/d49ff6ddd86ea57affa7e927797932bec1f9e5f2c9fa49a429ad2aac1b96/certbot-0.21.1-py2.py3-none-any.whl
Collecting certifi==2018.4.16 (from -r /usr/local/CyberCP/requirments.txt (line 9))
Using cached https://mirrors.aliyun.com/pypi/packages/7c/e6/92ad559b7192d846975fc916b65f667c7b8c3a32bea7372340bfe9a15fa5/certifi-2018.4.16-py2.py3-none-any.whl
Collecting cffi==1.11.5 (from -r /usr/local/CyberCP/requirments.txt (line 10))
Using cached https://mirrors.aliyun.com/pypi/packages/14/dd/3e7a1e1280e7d767bd3fa15791759c91ec19058ebe31217fe66f3e9a8c49/cffi-1.11.5-cp27-cp27mu-manylinux1_x86_64.whl
Collecting chardet==3.0.4 (from -r /usr/local/CyberCP/requirments.txt (line 11))
Using cached https://mirrors.aliyun.com/pypi/packages/bc/a9/01ffebfb562e4274b6487b4bb1ddec7ca55ec7510b22e4c51f14098443b8/chardet-3.0.4-py2.py3-none-any.whl
Collecting ConfigArgParse==0.13.0 (from -r /usr/local/CyberCP/requirments.txt (line 12))
Using cached https://mirrors.aliyun.com/pypi/packages/77/61/ae928ce6ab85d4479ea198488cf5ffa371bd4ece2030c0ee85ff668deac5/ConfigArgParse-0.13.0.tar.gz
Collecting configobj==4.7.2 (from -r /usr/local/CyberCP/requirments.txt (line 13))
Using cached https://mirrors.aliyun.com/pypi/packages/49/9c/4a97c36ba82e60b390614f050cd1d3e8652f1b38d1e6fde6e1ff4f16bc3e/configobj-4.7.2.tar.gz
Collecting cryptography==2.2.2 (from -r /usr/local/CyberCP/requirments.txt (line 14))
Using cached https://mirrors.aliyun.com/pypi/packages/dd/c2/3a5bfefb25690725824ade71e6b65449f0a9f4b29702cce10560f786ebf6/cryptography-2.2.2-cp27-cp27mu-manylinux1_x86_64.whl
Collecting decorator==3.4.0 (from -r /usr/local/CyberCP/requirments.txt (line 15))
Using cached https://mirrors.aliyun.com/pypi/packages/f3/26/876d492f2394f29401eb652ddfa53dec2bc8721861c7fe0dce1b5d0d2b6a/decorator-3.4.0.tar.gz
Collecting docker==3.6.0 (from -r /usr/local/CyberCP/requirments.txt (line 16))
Using cached https://mirrors.aliyun.com/pypi/packages/e1/58/938fbc7acd98302ca4872f5eab8ab811498e342ab5aec0c1609f22e0aeda/docker-3.6.0-py2.py3-none-any.whl
Collecting docker-pycreds==0.4.0 (from -r /usr/local/CyberCP/requirments.txt (line 17))
Using cached https://mirrors.aliyun.com/pypi/packages/f5/e8/f6bd1eee09314e7e6dee49cbe2c5e22314ccdb38db16c9fc72d2fa80d054/docker_pycreds-0.4.0-py2.py3-none-any.whl
Collecting Django==1.11 (from -r /usr/local/CyberCP/requirments.txt (line 18))
Using cached https://mirrors.aliyun.com/pypi/packages/47/a6/078ebcbd49b19e22fd560a2348cfc5cec9e5dcfe3c4fad8e64c9865135bb/Django-1.11-py2.py3-none-any.whl
Collecting docutils==0.14 (from -r /usr/local/CyberCP/requirments.txt (line 19))
Using cached https://mirrors.aliyun.com/pypi/packages/50/09/c53398e0005b11f7ffb27b7aa720c617aba53be4fb4f4f3f06b9b5c60f28/docutils-0.14-py2-none-any.whl
Collecting enum34==1.1.6 (from -r /usr/local/CyberCP/requirments.txt (line 20))
Using cached https://mirrors.aliyun.com/pypi/packages/c5/db/e56e6b4bbac7c4a06de1c50de6fe1ef3810018ae11732a50f15f62c7d050/enum34-1.1.6-py2-none-any.whl
Collecting funcsigs==1.0.2 (from -r /usr/local/CyberCP/requirments.txt (line 21))
Using cached https://mirrors.aliyun.com/pypi/packages/69/cb/f5be453359271714c01b9bd06126eaf2e368f1fddfff30818754b5ac2328/funcsigs-1.0.2-py2.py3-none-any.whl
Collecting future==0.16.0 (from -r /usr/local/CyberCP/requirments.txt (line 22))
Using cached https://mirrors.aliyun.com/pypi/packages/00/2b/8d082ddfed935f3608cc61140df6dcbf0edea1bc3ab52fb6c29ae3e81e85/future-0.16.0.tar.gz
Collecting futures==3.2.0 (from -r /usr/local/CyberCP/requirments.txt (line 23))
Using cached https://mirrors.aliyun.com/pypi/packages/2d/99/b2c4e9d5a30f6471e410a146232b4118e697fa3ffc06d6a65efde84debd0/futures-3.2.0-py2-none-any.whl
Collecting idna==2.6 (from -r /usr/local/CyberCP/requirments.txt (line 24))
Using cached https://mirrors.aliyun.com/pypi/packages/27/cc/6dd9a3869f15c2edfab863b992838277279ce92663d334df9ecf5106f5c6/idna-2.6-py2.py3-none-any.whl
Collecting iniparse==0.4 (from -r /usr/local/CyberCP/requirments.txt (line 25))
Using cached https://mirrors.aliyun.com/pypi/packages/0f/d1/3090ef9be165da5ddb1b0cf2b332d3282588bdd2dd0967e94b547f10055f/iniparse-0.4.tar.gz
Collecting ipaddress==1.0.16 (from -r /usr/local/CyberCP/requirments.txt (line 26))
Using cached https://mirrors.aliyun.com/pypi/packages/23/6a/813ac29a01e4c33c19c2bded98ac3d4266ebbf0bd2c0eb0020e1c969958d/ipaddress-1.0.16-py27-none-any.whl
Collecting IPy==0.75 (from -r /usr/local/CyberCP/requirments.txt (line 27))
ERROR: Could not find a version that satisfies the requirement IPy==0.75 (from -r /usr/local/CyberCP/requirments.txt (line 27)) (from versions: none)
ERROR: No matching distribution found for IPy==0.75 (from -r /usr/local/CyberCP/requirments.txt (line 27))

[05-46-33-Fri-Aug-2019] #########################################################################

[05-46-33-Fri-Aug-2019] CyberPanel requirements failed, trying again, try number: 1

[05-46-33-Fri-Aug-2019] #########################################################################

DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at Release process - pip documentation v22.0.dev0
Looking in indexes: Simple Index
Collecting acme==0.21.1 (from -r /usr/local/CyberCP/requirments.txt (line 1))
Using cached https://mirrors.aliyun.com/pypi/packages/d8/83/d37e3598e8aff2e52d6e1b49aaae6cab548ca62595a4634c459c808b4557/acme-0.21.1-py2.py3-none-any.whl
Collecting asn1crypto==0.24.0 (from -r /usr/local/CyberCP/requirments.txt (line 2))
Using cached https://mirrors.aliyun.com/pypi/packages/ea/cd/35485615f45f30a510576f1a56d1e0a7ad7bd8ab5ed7cdc600ef7cd06222/asn1crypto-0.24.0-py2.py3-none-any.whl
Collecting Babel==0.9.6 (from -r /usr/local/CyberCP/requirments.txt (line 3))
Using cached https://mirrors.aliyun.com/pypi/packages/47/d8/84943abdffcc0f910327a08651e857e682efcda80e6650b1aa93679d5f60/Babel-0.9.6.tar.gz
Collecting bcrypt==3.1.7 (from -r /usr/local/CyberCP/requirments.txt (line 4))
Using cached https://mirrors.aliyun.com/pypi/packages/ad/36/9a0227d048e98409f012570f7bef8a8c2373b9c9c5dfbf82963cbae05ede/bcrypt-3.1.7-cp27-cp27mu-manylinux1_x86_64.whl
Collecting backports.ssl-match-hostname==3.5.0.1 (from -r /usr/local/CyberCP/requirments.txt (line 5))
Using cached https://mirrors.aliyun.com/pypi/packages/76/21/2dc61178a2038a5cb35d14b61467c6ac632791ed05131dda72c20e7b9e23/backports.ssl_match_hostname-3.5.0.1.tar.gz
Collecting boto3==1.9.64 (from -r /usr/local/CyberCP/requirments.txt (line 6))
Using cached https://mirrors.aliyun.com/pypi/packages/5c/3a/da62fd31ae6154fe32485f067c4ef9a3dc65880fee9d2b189a1d6c17def8/boto3-1.9.64-py2.py3-none-any.whl
Collecting botocore==1.12.64 (from -r /usr/local/CyberCP/requirments.txt (line 7))
Using cached https://mirrors.aliyun.com/pypi/packages/98/8b/490e56b674f9a4cc750ae3588dcf300a57b84f7d1f80daf0b21b3e4f1d1f/botocore-1.12.64-py2.py3-none-any.whl
Collecting certbot==0.21.1 (from -r /usr/local/CyberCP/requirments.txt (line 8))
Using cached https://mirrors.aliyun.com/pypi/packages/47/16/d49ff6ddd86ea57affa7e927797932bec1f9e5f2c9fa49a429ad2aac1b96/certbot-0.21.1-py2.py3-none-any.whl
Collecting certifi==2018.4.16 (from -r /usr/local/CyberCP/requirments.txt (line 9))
Using cached https://mirrors.aliyun.com/pypi/packages/7c/e6/92ad559b7192d846975fc916b65f667c7b8c3a32bea7372340bfe9a15fa5/certifi-2018.4.16-py2.py3-none-any.whl
Collecting cffi==1.11.5 (from -r /usr/local/CyberCP/requirments.txt (line 10))
Using cached https://mirrors.aliyun.com/pypi/packages/14/dd/3e7a1e1280e7d767bd3fa15791759c91ec19058ebe31217fe66f3e9a8c49/cffi-1.11.5-cp27-cp27mu-manylinux1_x86_64.whl
Collecting chardet==3.0.4 (from -r /usr/local/CyberCP/requirments.txt (line 11))
Using cached https://mirrors.aliyun.com/pypi/packages/bc/a9/01ffebfb562e4274b6487b4bb1ddec7ca55ec7510b22e4c51f14098443b8/chardet-3.0.4-py2.py3-none-any.whl
Collecting ConfigArgParse==0.13.0 (from -r /usr/local/CyberCP/requirments.txt (line 12))
Using cached https://mirrors.aliyun.com/pypi/packages/77/61/ae928ce6ab85d4479ea198488cf5ffa371bd4ece2030c0ee85ff668deac5/ConfigArgParse-0.13.0.tar.gz
Collecting configobj==4.7.2 (from -r /usr/local/CyberCP/requirments.txt (line 13))
Using cached https://mirrors.aliyun.com/pypi/packages/49/9c/4a97c36ba82e60b390614f050cd1d3e8652f1b38d1e6fde6e1ff4f16bc3e/configobj-4.7.2.tar.gz
Collecting cryptography==2.2.2 (from -r /usr/local/CyberCP/requirments.txt (line 14))
Using cached https://mirrors.aliyun.com/pypi/packages/dd/c2/3a5bfefb25690725824ade71e6b65449f0a9f4b29702cce10560f786ebf6/cryptography-2.2.2-cp27-cp27mu-manylinux1_x86_64.whl
Collecting decorator==3.4.0 (from -r /usr/local/CyberCP/requirments.txt (line 15))
Using cached https://mirrors.aliyun.com/pypi/packages/f3/26/876d492f2394f29401eb652ddfa53dec2bc8721861c7fe0dce1b5d0d2b6a/decorator-3.4.0.tar.gz
Collecting docker==3.6.0 (from -r /usr/local/CyberCP/requirments.txt (line 16))
Using cached https://mirrors.aliyun.com/pypi/packages/e1/58/938fbc7acd98302ca4872f5eab8ab811498e342ab5aec0c1609f22e0aeda/docker-3.6.0-py2.py3-none-any.whl
Collecting docker-pycreds==0.4.0 (from -r /usr/local/CyberCP/requirments.txt (line 17))
Using cached https://mirrors.aliyun.com/pypi/packages/f5/e8/f6bd1eee09314e7e6dee49cbe2c5e22314ccdb38db16c9fc72d2fa80d054/docker_pycreds-0.4.0-py2.py3-none-any.whl
Collecting Django==1.11 (from -r /usr/local/CyberCP/requirments.txt (line 18))
Using cached https://mirrors.aliyun.com/pypi/packages/47/a6/078ebcbd49b19e22fd560a2348cfc5cec9e5dcfe3c4fad8e64c9865135bb/Django-1.11-py2.py3-none-any.whl
Collecting docutils==0.14 (from -r /usr/local/CyberCP/requirments.txt (line 19))
Using cached https://mirrors.aliyun.com/pypi/packages/50/09/c53398e0005b11f7ffb27b7aa720c617aba53be4fb4f4f3f06b9b5c60f28/docutils-0.14-py2-none-any.whl
Collecting enum34==1.1.6 (from -r /usr/local/CyberCP/requirments.txt (line 20))
Using cached https://mirrors.aliyun.com/pypi/packages/c5/db/e56e6b4bbac7c4a06de1c50de6fe1ef3810018ae11732a50f15f62c7d050/enum34-1.1.6-py2-none-any.whl
Collecting funcsigs==1.0.2 (from -r /usr/local/CyberCP/requirments.txt (line 21))
Using cached https://mirrors.aliyun.com/pypi/packages/69/cb/f5be453359271714c01b9bd06126eaf2e368f1fddfff30818754b5ac2328/funcsigs-1.0.2-py2.py3-none-any.whl
Collecting future==0.16.0 (from -r /usr/local/CyberCP/requirments.txt (line 22))
Using cached https://mirrors.aliyun.com/pypi/packages/00/2b/8d082ddfed935f3608cc61140df6dcbf0edea1bc3ab52fb6c29ae3e81e85/future-0.16.0.tar.gz
Collecting futures==3.2.0 (from -r /usr/local/CyberCP/requirments.txt (line 23))
Using cached https://mirrors.aliyun.com/pypi/packages/2d/99/b2c4e9d5a30f6471e410a146232b4118e697fa3ffc06d6a65efde84debd0/futures-3.2.0-py2-none-any.whl
Collecting idna==2.6 (from -r /usr/local/CyberCP/requirments.txt (line 24))
Using cached https://mirrors.aliyun.com/pypi/packages/27/cc/6dd9a3869f15c2edfab863b992838277279ce92663d334df9ecf5106f5c6/idna-2.6-py2.py3-none-any.whl
Collecting iniparse==0.4 (from -r /usr/local/CyberCP/requirments.txt (line 25))
Using cached https://mirrors.aliyun.com/pypi/packages/0f/d1/3090ef9be165da5ddb1b0cf2b332d3282588bdd2dd0967e94b547f10055f/iniparse-0.4.tar.gz
Collecting ipaddress==1.0.16 (from -r /usr/local/CyberCP/requirments.txt (line 26))
Using cached https://mirrors.aliyun.com/pypi/packages/23/6a/813ac29a01e4c33c19c2bded98ac3d4266ebbf0bd2c0eb0020e1c969958d/ipaddress-1.0.16-py27-none-any.whl
Collecting IPy==0.75 (from -r /usr/local/CyberCP/requirments.txt (line 27))
ERROR: Could not find a version that satisfies the requirement IPy==0.75 (from -r /usr/local/CyberCP/requirments.txt (line 27)) (from versions: none)
ERROR: No matching distribution found for IPy==0.75 (from -r /usr/local/CyberCP/requirments.txt (line 27))

[05-46-41-Fri-Aug-2019] #########################################################################

[05-46-41-Fri-Aug-2019] CyberPanel requirements failed, trying again, try number: 2

[05-46-41-Fri-Aug-2019] #########################################################################

DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at Release process - pip documentation v22.0.dev0
Looking in indexes: Simple Index
Collecting acme==0.21.1 (from -r /usr/local/CyberCP/requirments.txt (line 1))
Using cached https://mirrors.aliyun.com/pypi/packages/d8/83/d37e3598e8aff2e52d6e1b49aaae6cab548ca62595a4634c459c808b4557/acme-0.21.1-py2.py3-none-any.whl
Collecting asn1crypto==0.24.0 (from -r /usr/local/CyberCP/requirments.txt (line 2))
Using cached https://mirrors.aliyun.com/pypi/packages/ea/cd/35485615f45f30a510576f1a56d1e0a7ad7bd8ab5ed7cdc600ef7cd06222/asn1crypto-0.24.0-py2.py3-none-any.whl
Collecting Babel==0.9.6 (from -r /usr/local/CyberCP/requirments.txt (line 3))
Using cached https://mirrors.aliyun.com/pypi/packages/47/d8/84943abdffcc0f910327a08651e857e682efcda80e6650b1aa93679d5f60/Babel-0.9.6.tar.gz
Collecting bcrypt==3.1.7 (from -r /usr/local/CyberCP/requirments.txt (line 4))
Using cached https://mirrors.aliyun.com/pypi/packages/ad/36/9a0227d048e98409f012570f7bef8a8c2373b9c9c5dfbf82963cbae05ede/bcrypt-3.1.7-cp27-cp27mu-manylinux1_x86_64.whl
Collecting backports.ssl-match-hostname==3.5.0.1 (from -r /usr/local/CyberCP/requirments.txt (line 5))
Using cached https://mirrors.aliyun.com/pypi/packages/76/21/2dc61178a2038a5cb35d14b61467c6ac632791ed05131dda72c20e7b9e23/backports.ssl_match_hostname-3.5.0.1.tar.gz
Collecting boto3==1.9.64 (from -r /usr/local/CyberCP/requirments.txt (line 6))
Using cached https://mirrors.aliyun.com/pypi/packages/5c/3a/da62fd31ae6154fe32485f067c4ef9a3dc65880fee9d2b189a1d6c17def8/boto3-1.9.64-py2.py3-none-any.whl
Collecting botocore==1.12.64 (from -r /usr/local/CyberCP/requirments.txt (line 7))
Using cached https://mirrors.aliyun.com/pypi/packages/98/8b/490e56b674f9a4cc750ae3588dcf300a57b84f7d1f80daf0b21b3e4f1d1f/botocore-1.12.64-py2.py3-none-any.whl
Collecting certbot==0.21.1 (from -r /usr/local/CyberCP/requirments.txt (line 8))
Using cached https://mirrors.aliyun.com/pypi/packages/47/16/d49ff6ddd86ea57affa7e927797932bec1f9e5f2c9fa49a429ad2aac1b96/certbot-0.21.1-py2.py3-none-any.whl
Collecting certifi==2018.4.16 (from -r /usr/local/CyberCP/requirments.txt (line 9))
Using cached https://mirrors.aliyun.com/pypi/packages/7c/e6/92ad559b7192d846975fc916b65f667c7b8c3a32bea7372340bfe9a15fa5/certifi-2018.4.16-py2.py3-none-any.whl
Collecting cffi==1.11.5 (from -r /usr/local/CyberCP/requirments.txt (line 10))
Using cached https://mirrors.aliyun.com/pypi/packages/14/dd/3e7a1e1280e7d767bd3fa15791759c91ec19058ebe31217fe66f3e9a8c49/cffi-1.11.5-cp27-cp27mu-manylinux1_x86_64.whl
Collecting chardet==3.0.4 (from -r /usr/local/CyberCP/requirments.txt (line 11))
Using cached https://mirrors.aliyun.com/pypi/packages/bc/a9/01ffebfb562e4274b6487b4bb1ddec7ca55ec7510b22e4c51f14098443b8/chardet-3.0.4-py2.py3-none-any.whl
Collecting ConfigArgParse==0.13.0 (from -r /usr/local/CyberCP/requirments.txt (line 12))
Using cached https://mirrors.aliyun.com/pypi/packages/77/61/ae928ce6ab85d4479ea198488cf5ffa371bd4ece2030c0ee85ff668deac5/ConfigArgParse-0.13.0.tar.gz
Collecting configobj==4.7.2 (from -r /usr/local/CyberCP/requirments.txt (line 13))
Using cached https://mirrors.aliyun.com/pypi/packages/49/9c/4a97c36ba82e60b390614f050cd1d3e8652f1b38d1e6fde6e1ff4f16bc3e/configobj-4.7.2.tar.gz
Collecting cryptography==2.2.2 (from -r /usr/local/CyberCP/requirments.txt (line 14))
Using cached https://mirrors.aliyun.com/pypi/packages/dd/c2/3a5bfefb25690725824ade71e6b65449f0a9f4b29702cce10560f786ebf6/cryptography-2.2.2-cp27-cp27mu-manylinux1_x86_64.whl
Collecting decorator==3.4.0 (from -r /usr/local/CyberCP/requirments.txt (line 15))
Using cached https://mirrors.aliyun.com/pypi/packages/f3/26/876d492f2394f29401eb652ddfa53dec2bc8721861c7fe0dce1b5d0d2b6a/decorator-3.4.0.tar.gz
Collecting docker==3.6.0 (from -r /usr/local/CyberCP/requirments.txt (line 16))
Using cached https://mirrors.aliyun.com/pypi/packages/e1/58/938fbc7acd98302ca4872f5eab8ab811498e342ab5aec0c1609f22e0aeda/docker-3.6.0-py2.py3-none-any.whl
Collecting docker-pycreds==0.4.0 (from -r /usr/local/CyberCP/requirments.txt (line 17))
Using cached https://mirrors.aliyun.com/pypi/packages/f5/e8/f6bd1eee09314e7e6dee49cbe2c5e22314ccdb38db16c9fc72d2fa80d054/docker_pycreds-0.4.0-py2.py3-none-any.whl
Collecting Django==1.11 (from -r /usr/local/CyberCP/requirments.txt (line 18))
Using cached https://mirrors.aliyun.com/pypi/packages/47/a6/078ebcbd49b19e22fd560a2348cfc5cec9e5dcfe3c4fad8e64c9865135bb/Django-1.11-py2.py3-none-any.whl
Collecting docutils==0.14 (from -r /usr/local/CyberCP/requirments.txt (line 19))
Using cached https://mirrors.aliyun.com/pypi/packages/50/09/c53398e0005b11f7ffb27b7aa720c617aba53be4fb4f4f3f06b9b5c60f28/docutils-0.14-py2-none-any.whl
Collecting enum34==1.1.6 (from -r /usr/local/CyberCP/requirments.txt (line 20))
Using cached https://mirrors.aliyun.com/pypi/packages/c5/db/e56e6b4bbac7c4a06de1c50de6fe1ef3810018ae11732a50f15f62c7d050/enum34-1.1.6-py2-none-any.whl
Collecting funcsigs==1.0.2 (from -r /usr/local/CyberCP/requirments.txt (line 21))
Using cached https://mirrors.aliyun.com/pypi/packages/69/cb/f5be453359271714c01b9bd06126eaf2e368f1fddfff30818754b5ac2328/funcsigs-1.0.2-py2.py3-none-any.whl
Collecting future==0.16.0 (from -r /usr/local/CyberCP/requirments.txt (line 22))
Using cached https://mirrors.aliyun.com/pypi/packages/00/2b/8d082ddfed935f3608cc61140df6dcbf0edea1bc3ab52fb6c29ae3e81e85/future-0.16.0.tar.gz
Collecting futures==3.2.0 (from -r /usr/local/CyberCP/requirments.txt (line 23))
Using cached https://mirrors.aliyun.com/pypi/packages/2d/99/b2c4e9d5a30f6471e410a146232b4118e697fa3ffc06d6a65efde84debd0/futures-3.2.0-py2-none-any.whl
Collecting idna==2.6 (from -r /usr/local/CyberCP/requirments.txt (line 24))
Using cached https://mirrors.aliyun.com/pypi/packages/27/cc/6dd9a3869f15c2edfab863b992838277279ce92663d334df9ecf5106f5c6/idna-2.6-py2.py3-none-any.whl
Collecting iniparse==0.4 (from -r /usr/local/CyberCP/requirments.txt (line 25))
Using cached https://mirrors.aliyun.com/pypi/packages/0f/d1/3090ef9be165da5ddb1b0cf2b332d3282588bdd2dd0967e94b547f10055f/iniparse-0.4.tar.gz
Collecting ipaddress==1.0.16 (from -r /usr/local/CyberCP/requirments.txt (line 26))
Using cached https://mirrors.aliyun.com/pypi/packages/23/6a/813ac29a01e4c33c19c2bded98ac3d4266ebbf0bd2c0eb0020e1c969958d/ipaddress-1.0.16-py27-none-any.whl
Collecting IPy==0.75 (from -r /usr/local/CyberCP/requirments.txt (line 27))
ERROR: Could not find a version that satisfies the requirement IPy==0.75 (from -r /usr/local/CyberCP/requirments.txt (line 27)) (from versions: none)
ERROR: No matching distribution found for IPy==0.75 (from -r /usr/local/CyberCP/requirments.txt (line 27))

[05-46-51-Fri-Aug-2019] #########################################################################

[05-46-51-Fri-Aug-2019] CyberPanel requirements failed, trying again, try number: 3

[05-46-51-Fri-Aug-2019] #########################################################################

[05-46-51-Fri-Aug-2019] #########################################################################

[05-46-51-Fri-Aug-2019] CyberPanel requirements failed.

[05-46-51-Fri-Aug-2019] #########################################################################

I think the issue might be this

Collecting IPy==0.75 (from -r /usr/local/CyberCP/requirments.txt (line 27))
ERROR: Could not find a version that satisfies the requirement IPy==0.75 (from -r /usr/local/CyberCP/requirments.txt (line 27)) (from versions: none)
ERROR: No matching distribution found for IPy==0.75 (from -r /usr/local/CyberCP/requirments.txt (line 27))

Can you DM SSH login ? and make a snapshot backup beforehand.

@qtwrk Thank you for your help. However, I moved my server from Alibaba to another company.

The new server is Centos7.
Commands I run to install Cyberpanel:

The some of logs:
ERROR: Could not find a version that satisfies the requirement IPy==0.75 (from -r /usr/local/CyberCP/requirments.txt (line 27)) (from versions: none)
ERROR: No matching distribution found for IPy==0.75 (from -r /usr/local/CyberCP/requirments.txt (line 27))

ate pecl.php.net" to update
downloading timezonedb-2019.2.tgz …
Starting to download timezonedb-2019.2.tgz (413,162 bytes)
…done: 413,162 bytes
ERROR: Unknown Role class: “PEAR_Installer_Role_Pear_Installer_role_src”
WARNING: channel “pecl.php.net” has updated its protocols, use “pecl channel-update pecl.php.net” to update
downloading timezonedb-2019.2.tgz …
Starting to download timezonedb-2019.2.tgz (413,162 bytes)
…done: 413,162 bytes
ERROR: Unknown Role class: “PEAR_Installer_Role_Pear_Installer_role_src”
WARNING: channel “pecl.php.net” has updated its protocols, use “pecl channel-update pecl.php.net” to update
downloading timezonedb-2019.2.tgz …
Starting to download timezonedb-2019.2.tgz (413,162 bytes)
…done: 413,162 bytes
ERROR: Unknown Role class: “PEAR_Installer_Role_Pear_Installer_role_src”
Admin password successfully changed!

Cyberpanel is installed but I hope the above errors won’t cause any issue. Best regards.

I think the last 2 about pecl won’t effect, but not sure about that pip thing ,

may I know what is this provider ? I can purchase a VPS and run some test.

if you use MacOs terminal try to any windows pc.

@qtwrk thank you. Every function of the panel is working well. I just ignored these issues.

But I’m just wondering why it didn’t work well on Alibaba Cloud.

@maksim yes. Yes, my computer is a macOS. But are you sure? It is related to OS?

@qtwrk thank you. Every function of the panel is working well. I just ignored these issues.

But I’m just wondering why it didn’t work well on Alibaba Cloud.

@maksim yes. Yes, my computer is a macOS. But are you sure? It is related to OS?

yes. I was getting the same mistakes in my macOS (mojave and high sierra). Windows putty also does not give this “ERROR: Could not find a version that satisfies the requirement IPy==0.75…” error during installation and update.

@maksim I’ll try to install CyberPanel on Termius first, and then Windows Putty. Thank you very much.

I’m running cyberpanel on Alibaba ECS with no problem at all.