Cyberpanel IP address is different from my VM IP on Google Cloud

Hello everyone, my name is izzet. I have a question. i installed cyberpanel on google cloud after that i get a static ip for my google cloud. After that i check the ip cyber panel’s and my vm ip is different.

After that i insatalled second cyber panel to another vm there is no problem. ip’s same but my old one is different. i am adding a ss. Could you please help me ? is that cause me a problem or there is no problem

Welcome and Happy New Year @izzet

Log into your server using SSH

Run nano /etc/cyberpanel/machineIP || vi /etc/cyberpanel/machineIP

Change the ip you see there to the correct one

1 Like

sorry i am really new here and using ssh panels. Is this affect to my websites ? thank you for answer

No the command will just adjust the ip address for the panel (django side) not affect anything else like hosting technologies. Your websites will not be affected at all.

If you are using Mac or Windows I would recommend Bitvise SSH Client for windows and ‎Termius - SSH & SFTP client on the Mac App Store for Mac. Read the docs to connect to ssh (these clients as easy to use)

i am connecting with google cloud on cyberpanel field. i connected i change it, i couldnt approving. When i hit enter, nothing happened.

                          [ File '/etc/cyberpanel/machineIP' is unwritable ]

Do you have sudo user or root access to said server?

If not create a SSH key and specify in your project or instance metadata

You can modify the PermitRootLogin parameter in Linux VM’s /etc/ssh/sshd_config, however, Google recommends running commands through sudo instead e.g.

sudo nano /etc/cyberpanel/machineIP

Yes , thank you i forgot to get back to root user. When i change root user, ip adress changed. After that i reboot with ssh than its looking same ip adress. Thank you for your helping, last question if you dont mind. Why ip adress still looking red color :sweat_smile:

the color red makes you think something is not right :sweat_smile:

my other vm cyber panel ip is green one.

Interesting which version are you using? You should probably run an upgrade and reboot the server 02 - Upgrading CyberPanel or run

sudo service lscpd restart && sudo service lsws reload

Post a screenshot of https://SERVER_URL:8090/base/versionManagment

how can i upgrade is there a video tutorial ?
or this code enough for upgrading

sudo service lscpd restart && sudo service lsws reload

See if this remedies the issue

1 Like

Run the commands line by line without copying the dollar sign $

$ sudo su - -c "sh <(curl || wget -O -"
$ sudo service lscpd restart && sudo service lsws reload
1 Like

YES. Thank you so so so much for your helping. I upgraded and now everythings fine. Thank you so much. Thank you. :smiling_face: :smile:

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.