CyberPanel IP:8090 Access 500 Internal Server Server Error

Dear cyberpanel,

I Got 500 Internal Server Error from Cyberpanel IP:8090.
Website and WebAdmin :7080 is working fine.
I tried systemctl restart lscpd - and its running just fine.
Sometimes having the same problem.

How can I solve this permanently?



I used the v2.1.2 Stable. there was no problem. but for some reason i upgrade to the latest 2.3.2 stable.since then this problem started. then i downgrade to 2.1.2 stable. but the problem is not solved.

Hello @rashedit, Happy to have you

  1. Run command touch /usr/local/CyberCP/debug, this will start generating more debug logs
  2. Run CyberP upgrade
  3. Post the contents of your /home/cyberpanel/error-logs.txt , /usr/local/lsws/logs/access.log and /usr/local/lsws/logs/error.log
  4. Post the contents of the service status:
$ sudo service lscpd status

I see you did not run an upgrade.

Here is a guide of how to upgrade CyberP in summary the command is:

sh <(curl || wget -O -

You still have 500 error?

  1. Does this affect the admin panel only?

  2. You might need to do Enable Django Debug Logs (To find out reason for 500 error on CyberPanel)

when i restart server or cyberpanel then it’s works fine.
after some time passed the problem appeared but all website is working.

yes only admin panel.

Then we can rule out an OLS issue assuming you did not tamper with default installation. Post the result of systemctl status mariadb

Maybe some packages of mariadb is missing/deleted by the OS while doing some upgrade or update actions

If the problem is still unresolved, I will suggest you to reinstall mariadb (be careful while doing this as its sensitive…if anything wrong happens, your mariadb will be down and thus all your sites). Better you take snapshot of your whole server before trying this for safety.

Follow this method: Upgrading MariaDB manually - #3 by nick.chomey

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.