CyberPanel installation Ubuntu 20.04.4 LTS


It seems there’s a problem with the installation on Ubuntu 20.04.4.

I’m running as root (su - ):

sh <(curl || wget -O -

on a fresh Ubuntu installation and I’m getting

chmod: cannot access '': No such file or directory
/dev/fd/63: 46: ./ not found

Any ideas?

Here’s the full output:

# sh <(curl || wget -O -
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1802  100  1802    0     0   9147      0 --:--:-- --:--:-- --:--:--  9101
curl is already the newest version (7.68.0-1ubuntu2.11).
wget is already the newest version (1.20.3-1ubuntu2).
The following package was automatically installed and is no longer required:
Use 'apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
chmod: cannot access '': No such file or directory
/dev/fd/63: 46: ./ not found

recommended to do:

sudo su -
cd /usr/local/tmp
sh <(curl || wget -O -

its NOT that simple,
after a new installation in the login ip it asks for an phpmyadmin user/pass.

Cyberpanel login screen has disappeared since the last update!

1 Like

this mean you are success to install now

that is BIG BUG 2.3.2

install with 2.3.1 and do not do upgrade

+1, I have the same problem

[BUG] Redirect when access port 8090 to phpmyadmin and not a panel - CyberPanel Project / Bug Report - CyberPanel Community

Doesn’t work on 2.3.1 (Ubuntu 20.04). Selected this version during installation instead of the latest.

How did you install 2.3.1 version and what OS?

Hello, thanks for the suggestion!

I tried installing 2.3.1 in a clean ubuntu but it doesn’t work, I still have phpMyAdmin login!
I will try an older version also!

Have you tried another OS?

I will do it and report back
Please give me the olders versions to check

I’ve tried cent OS, same problem

hello guys.

seems that the problem is not that serious, just put /base after the port, like this:

Mine its from upgrade so its cached and I can see the cyberpanel in rocky linux!
But in ubuntu it doesn’t work at all!



  • Server with a fresh install of Centos 7.x, Centos 8.x, Ubuntu 18.04, Ubuntu 20.04, AlmaLinux 8

Yes I know, tis not in the requirements but its working!

omg… i cant tell anything… is all version are broken ?

actually not… i was always bookmark my panel page to https://domain:8090/base/

but you can try https://domain:8090/logout

Yes my ubuntu VPS doesn’t working also , only the rocky linux one!

i use ubuntu…
does anyone can “read” the source about 8090 login ? perhaps it load something like “remote” proxy onto cyberpanel environment ?

I’m sorry but how did we end up talking about the port 8090? It doesn’t even run the installer… This thread is going places…

Maybe your dns have problem to access cyberpanel server. Try change your server DNS first.