CyberPanel Installation Stuck at Swap

Salam n Hola

Provider: Internal Corporate VMWare Infrastructure

Virtualization Type: VMWare

System: Centos 7.9

Installation option:

OLS or Enterprise?

Install Memcached?

Install Redis?


Cloning into ‘cyberpanel’…
remote: Enumerating objects: 25790, done.
remote: Counting objects: 100% (1864/1864), done.
remote: Compressing objects: 100% (784/784), done.
remote: Total 25790 (delta 1188), reused 1563 (delta 1004), pack-reused 23926
Receiving objects: 100% (25790/25790), 362.06 MiB | 924.00 KiB/s, done.
Resolving deltas: 100% (16469/16469), done.
Checking out files: 100% (4323/4323), done.

CyberPanel source code downloaded…

Branch ‘v2.1.1’ set up to track remote branch ‘v2.1.1’ from ‘origin’.
Switched to a new branch ‘v2.1.1’
Setting up swapspace version 1, size = 2097148 KiB
no label, UUID=1b14b447-518e-465e-a236-1b251a7e2471
swapon: /cyberpanel.swap: swapon failed: Invalid argument
/cyberpanel.swap swap swap sw 0 0
vm.swappiness = 10

SWAP set…

Installation stuck at the above SWAP set.
I tried re-install on clean centos 7 … same thing happens

Looking at messages in /var/log I see the following:

Aug 3 23:40:43 prod kernel: swapon: swapfile has holes

Following is the content of installLogs.txt:

[root@prod log]# more installLogs.txt

Starting installation…,1

Initialization completed…,2

Setting up repositories…,1

Installing necessary components…,3

Installing required virtual environment,3

Installing requirments…,3

Getting CyberPanel code…,4

Necessary components installed…,5

Setting up system tweak…,20

Any assistance is greatly appreciated.

Cyberpanel install script does not work at all!

I have absolutely same issue on fresh Ubuntu 18 04 VPS

Its always getting stuck on “SWAP set…”
Like this: Screenshot - e1958286278314bd6dc76248e3f11164 - Gyazo

also after all this none of the outgoing connections work at all

(i can connect to the server via ssh normally, but no outgoing requests are working. ping\apt update\wget etc. )
UFW disabled. Iptables flushed. I have tried everything.

So the install script not only not working but it also breaks the system.

And no answer I am getting same error in Ubuntu 20.04