Cyberpanel delete all files and directors public_html

I think the last test to do is the out of disk space, can anyone test? i need to get back on track in my work timeline.

I will check disk space and your comments above and revert to you soon.

1 Like

i will update my panel now… and test it

I removed the command part from logs, and ran tests on various things and it seems to resolve all cases.

  1. Disk space
  2. Or permission issue

Thanks alot


Just wanted to chime in on this thread.

I’m by no means a sysadmin or a dev expert, but consider myself proficient enough to run a website using AWS and Cyberpanel.

This morning, I woke up to find our entire site completely gone. Wiped, deleted, no files, nothing.

Thankfully we have backups on AWS which we were able to restore, but I also had Google Drive backups enabled for good measure as the site is very large, 11 years old, has millions of users a month and is the heart of our small business.

To wake up and to find that completely missing was completely incomprehensible to me. After thinking we’d been hacked, only after several hours of digging did we find this thread and realise that Cyberpanel had literally deleted all our files in our /public_html folder.


I am far calmer now we’ve fixed the problem and found this thread, but I just wanted to put on the record how stressful this experience has been, how a small business could literally have been decimated overnight and how this shouldn’t even be able to happen in what is meant to be an advanced system. Deleting all files without any kind of check or prevention before it happens is the worst possible thing that can happen to a company.

And the fact it happened this morning on a STABLE BUILD of this product is frankly criminal.

Just my two cents - and I know they won’t be popular.


@dazburn Precisely this. The last thing you’d expect your backup service to do is wipe out your files.

@ricardojds is correct regarding what is happening. Despite the comments made by the dev team in this thread claiming that it was fixed, the code is still there as of v2.1.2 Stable.

/plogical/ Edit: 378

This seems pretty uncalled for given that we are talking about a backup system. But yeah, god help anyone who didn’t make a backup — before making a backup.

1 Like

The line changed to avoid the isso is line 378
raise BaseException(f'Failed to run cp command during backup generation.')
before there was injected the command string to the exception message.

@edwardm can you confirm the date you installed cyberpanel and the date you configured the backup or run manualy the backup?

first of all I want to say welcome to this forum

I’d like to say that I heard that some people did experience deletion of content from public_html
Luckily I didn’t experience this

Can you tell me when you last accessed or installed something in public_html ?

based on: Cyberpanel delete all files and directors public_html - #92 by usmannasir

the problem happened instantly

@edwardm :

i think what happen with @dazburn is not about the backup
he woke up and …zaaappp empty public_html but still have wp-content (that might not deleted becaus it “not-listed” or have custom folder…like uploads)

sorry to reply this…
you mean… to prevent this bug, i will need create new fresh backup ?

That message was for @dazburn i missed the mention :rofl:
He said the site was 11 year old i wanted to know when did he migrated the site to cyberpanel and when did he run or configure the backup or if it deleted even when he didnt configure no backups.

You’re like putting a bomb under my chair
so any backup will safe ?

There was nothing in wp-content - it was blank.

I migrated on 2nd March. Google Drive backups worked for a few days, then stopped earlier this week. But that was a few days ago. Overnight last night is when everything disappeared at 00:30 - the same time Google Drive backup was running by Cyberpanel.

Not actually right. I worked with him on this issue. The contents of the entire public_html directory were wiped out (i.e. wp-content didn’t exist either), and later the LiteSpeed service generated a ucss folder inside it which also generated the parent directory.

This was not user error and you can actually see in the syslog file exactly when the backup failed due to lack of space this morning — one minute before our website uptime checker started sending notifications about the site being inaccessible.

All the other logs consistently mention the server running out of diskspace around this time.

The logged failed backup time is also the time when our diskspace usage saw a sharp drop, pointing again to the fact that the entire website contents were removed at the very same moment that the CyberPanel backup script ran.

We went through all the logs for services, auth and access with a fine tooth comb and it led to nothing until we found that the rm command targets the wrong directory if it encounters a diskspace error.

1 Like

why it not removed just like other folder like wp-admin wp include… weird… then maybe this is another cases…

you can create new thread…
so community can help you figure it out
because your plugin that have backdoor… or old version of wp… or leak of credential… everything can be happen

Read my reply above yours, it explains why it seemed like wp-content was there.

better to create new thread for you both…

@MyIDKaTePe A new thread would be pointless because this thread is the one relevant to the issue. Read my reply for the explanation, you are assuming a lot and you happen to be wrong.

create new thread.
then put ref: this thread

why ? if you need community help then you need they to focus.
as you can see this thread actually created not related to your case that not “instantly-deleted”
and already marked “solved”

so you can repeat the process then

can you create the video with the process ?
so the developer and other community member can see the problem easier