Cyberpanel can't upgrade to the latest commit! ( not found)

I’m trying to update Cyberpanel and we’re facing some annoying problems.
I have version 2.3.4 installed on Ubuntu 20.04 and I am trying to update to the latest commit.

This is the error I get on ssh:

This is the error I get from Version management:

1 Like

Ahh. I’m getting the exact same issue as well. I tried to manually upgrade, but I’m not having any luck. Perhaps you can try running these commands in terminal:

As Root (sudo su -), run


Then run:

chmod +x

Then run:


Unfortunately, for me, it doesn’t work - but hopefully it helps to fix your issue. I think the CyberPanel team must have broken something recently. I was able to upgrade one of my servers via the standard process, however, my main server is getting the same error as yours. I also get the Server Error (500) when visiting the version management page.

im getting exactly the same issue
any help

1 Like

Check my response above and let us know how you go.

yes thank you I tried but nothing to do.

We have also tried this method but it does not work because the source from Github is not accessible.
Based on my investigations, it turns out that this whole problem comes from the github source.

Hello, thanks so what we have to do ?

We have to wait for @usmannasir to solve it.

All right thanks