CronJob does not run

Good morning Community! I hope everyone is well.
I’m trying to run a cronjob that I defined:

The problem is that it doesn’t work, cron just doesn’t work. However, if you take the same command and run it directly through the terminal, the file will run successfully. What can you celebrate?

I have already tried restarting the cron service using the command: service cron restart but without success.

Can you show me output when you run this command from cli? BTW this command require root privileges to run ?

@usmannasir It requires root privileges to run this way.
php /home/

The file itself is just a file that will call a function in Wordpress, as I need to use something that runs regardless of whether or not there are visits to the site, so Wordpress cron would not be of use to me. Is there another better way to execute this?

I also tried running using wget -O but also without success. What I find strange is running it through the CLI and it works, but if you leave it programmed through the Cron Job it doesn’t work.

I don’t know if it’s an option but I can provide access to my server. I will send the credentials privately if needed.

If your command requires root access, then enter this cron in your root cron file from command line, because cron from CyberPanel will run for the website user only.

I wanted to run it without root access, as I mentioned earlier it was just a test, create it and run it as a cronjob. But it seems to me that there is a problem with cronjob.

Type if I just use:

Nothing is executed.

How can I check if there is a problem in cron?

Try to use journalctl to debug cron jobs or create 1minute cron job to create a test file and see if it works.

It worked using curl in the cron command