Creating website stuck on Starting Creation - AWS EC2

I tried to install cyberpanel on my AWS EC2 instance with this specification :
instance type = t2.medium
storage = 15GiB
OS = Ubuntu 20.04 LTS

Script i used to install CyberPanel :
sudo apt update && sudo apt upgrade -y
sudo su -
sh <(curl https://cyberpanel.net/install.sh || wget -O - https://cyberpanel.net/install.sh)

it all works, i can access cyber panel dashboard on port 8090, but when i tried to create a website it always stuck on starting creation. did i does something wrong ?

Welcome @Elvis Happy you are here

Run command touch /usr/local/CyberCP/debug, this will start generating more debug logs.

Also post the contents of https://<IP Address>:8090/serverstatus/cyberCPMainLogFile and /home/cyberpanel/error-logs.txt when you try to create website.

Sorry for my lack experience, i just started to learn this thing, after i run touch command it return nothing and what should i post in error-logs.txt ?

Yes it should return nothing. Now go try create a website. Once the process stalls or bugs out run this command nano /home/cyberpanel/error-logs.txt || vi /home/cyberpanel/error-logs.txt and post screenshot or copy-paste the result here


I stuck on here everytime i create website

How much memory do you have? Post the result of

echo $(($(getconf _PHYS_PAGES) * $(getconf PAGE_SIZE) / (1024 * 1024)))

I already change my memory size from 1 to 4 and still stucking on this creating website

Upgrade your copy and try again

sh <(curl https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh || wget -O - https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh)

i run this on new instance, and it return cannot detect CyberCP

Post screenshot here please

Post the result of ls -la /usr/local/CyberCP

I do have the same issue here, running on VPS with ubuntu 22.04 and 4GB of mem.
i have this file touched as requested here but no error log created

cat: /home/cyberpanel/error-logs.txt: No such file or directory

I see that i can run it through command line, this is what i get:
cyberpanel createWebsite --package Detault --owner admin --domainName example.us --email info@example.us --php 5.6
{“success”: 0, “errorMessage”: “Package matching query does not exist.”}

now i see in error-logs.txt file:

I fresh installed CP on AlmaLinux 8 and I got same issue and same error logs.
What is the solution?

1 Like