Creating FTP accounts getting: getpwnam(): name not found

I’m not sure what the exact issue is- the logs just say "getpwnam(): name not found ". the SQL database doesn’t show up in CP and I’m assuming it’s there just not in the panel? The DB name changes when I try creating new FTP accounts for different sites. This is a fresh new install on Ubuntu 20.04. I’m not sure how to proceed and the only other forum post here has no answers. I’ve tried to restart the service and switch to different users to no avail.

Any help on this would be greatly appreciated I can’t do anything until this gets resolved.

Not really fix to your problem but go around, try on cyperpanel website section upright corner setup SSH and connect with SFTP.

I’m sorry I’m not understanding you or I’m not able to find that function. The only thing I’m finding is Security>secure ssh> then options for turning it off and on as well as assigning keys. I’m unable to create any FTP account and I have login via root actively disabled for security (plus I don’t want to give root to my clients).

See attached image rounded set user SSH there and use those SSH credentials connect SFTP If you have SSH password authentication off you need to generate SSH keys.
That’s not fixing your FTP error for that maybe try upgrade cyperpanel SSH on root and use copy paste following line: sh <(curl || wget -O -

Ah thank you so much I feel so dumb for missing that :smiley:
So I have good news and bad news: The good news is that I found it, and set the password for ssh, the bad news is that when creating an ftp account it says the same error but I realized that the error isn’t a database, but the SSH username. It still can’t find it apparently?

Also not sure if this is related but it may be since, files, but when trying to install WP+LS Cache it instantly gives me a failed install 404 error. This error doesn’t show up in the error logs.

I’ve tried to upgrade all packages as root, and upgrade CP as root via the upgrade script. When that didn’t resolve the issue I wiped the server, reinstalled a clean stock Ubuntu 20.04 LTS image and did a clean install of CP still having the same issues. I’ve also tried manually install php-mysql as some other people have had success with that. Nothing seems to fix the issue. The panel also insists that PureFTP is not running but CLI tells me it is.

see image user name underlined with black

That is problem seems to come up time to time up here. Check from file manager if cyberpanel made all WP files and folders if so. Then make database manually and update database user, password and database prefix on wp-config.php file

Maybe admins could help better actually solve problems rather than go around them. @die2mrw007 @usmannasir

hopefully the admins can help.
In the meantime I’ve tried creating the FTP account with the SSH username and the same password- it still gives the error. In addition WordPress install still 404s and does not create any files (verified via SSH and file manager).

There’s no community Discord anymore? I saw a post about it from last year but can’t find it. Was hoping to try and get some real time help and share screen haha.

You don’t need to crate FTP account. With you FTP client choose connect with SFTP SSH file protocol and use those SSH credentials then connect. You can use it just like FTP but SFTP is more secure.

Right but I’m worried that the WP install issues stem from the FTP issues.

I also am getting "getpwnam(): name not found error when creating an FTP account for a specific website. All other websites work just fine. I deleted the website, waited a day, re-created it and the same error, the only thing that changes is the username for the FTP account. I tried to create a domain after deleting the domain in question just in case maybe there was an issue with the Domain ID in the DB, still the same issue and it is only for a specific domain name. I am at the point where I think I am just going to stand up a new Server, build the newest Version of Cyber Panel and just migrate everything over to that Server, create a backup and just keep going. Seems like Cyber Panel cant find the user for this domain giving that "getpwnam(): name not found error. Any suggestions before I build out a whole new server, Move 7 sites over, and re-do all my DNS?

I was able to get this resolved, so when you create the website you have to click on the “open_basedir Protection” option, I was viewing the /home directory where new sites are created and if you do not click that option then the site is created with Root as the owner as opposed to it creating a user for the site, so then permissions while viewing sites in file manager make it so you cant see the structure. This also causes new FTP accounts to not create because the error is saying “I don’t have a user attached to this site to create the FTP account”. Took me a while to figure this out but this is what worked for me. When you upload files to the public_html dir, I also had to Recursively add perms for the new user created. Hope this helps.