CPanel to CyberPanel Migration Error

Hi there,

I´m facing issue that trying to migrate a cpanel account to CyberPanel, Has anyone successfully migrate cpanel to cyberpanel in nowadays?

I came from Auto import cPanel sites to CyberPanel - CyberPanel and i tried every trick like;

/usr/local/CyberCP/bin/python3 /usr/local/CyberCP/plogical/cPanelImporter.py --path /home/backup/filename.tar.gz

/usr/local/CyberCP/bin/python3 /usr/local/CyberCP/plogical/cPanelImporter.py --path /home/backup

/usr/local/CyberCP/bin/python /usr/local/CyberCP/plogical/cPanelImporter.py --path /home/backup

/usr/local/CyberCP/bin/python3 /usr/local/CyberCP/plogical/cPanelImporter.py --path /home/backup/filename.tar.gz

Output is always same:

Backup logs to be generated in /home/cyberpanel/5131
Extracting main cPanel archive file: /home/backup/filename.tar.gz
/home/backup/filename.tar.gz successfully extracted.

Creating main account from archive file: /home/backup/filename.tar.gz

Failed to create main website from backup file /home/backup/filename.tar.gz, error message: [Errno 2] No such file or directory: ‘/home/backup/filename/userdata/main’.

Also on Web panel it failed though:

[Errno 2] No such file or directory: ‘/home/backup/filename/meta.xml’ [736][5009]

Yes, i did via the guide ( Auto import cPanel sites to CyberPanel - CyberPanel ) and download full backup from cPanel backup wizard. I also tried to wget to directly to home/backup but cant figure out what i missed? I would really like to know if their is some special configuration, modules, or anything else?

I’m also having the same problem, I’ve never been able to restore a backup by this command line tool.

I even think that this tool is a scam, because I didn’t see anyone saying they did it.

Many users successfully transfered their cpanel sites to cyberpanel using this tool. If you have issues, you need to atleast provide complete details to reproduce this issue along with all the logs it generated and the errors to identify your use case issue.

Also make sure to upgrade cyberpanel using SSH upgrade command.

Also, mentioning a tool as scam is inappropriate as cyberpanel is an open-source platform. You can either use it or ignore it.

The restore command for cPanel backup just doesn’t work as expected.

Just now I ran the command to restore a cPanel account, the ackup was present in /home/backup
I ran the command: /usr/local/CyberCP/bin/python /usr/local/CyberCP/plogical/cPanelImporter.py --path /home/backup

The account was created, but without public_html.

The tool creates ONLY the logs and lscache folders, nothing else.

So I can say that this migration tool does not work, or is outdated due to several cPanel updates.


Screenshot_106

I will have a check and revert. What was your cPanel version number from where you took the backup?

cPanel v100.0.5

I just spinned a new vps in digital ocean to check cPanel v100.0.5 created backup file to cyberpanel v2.1.2 and the script ran perfectly fine without issues and everything migrated successfully including all the files and databases.

So, I can say that there is something wrong with your end.

can you send the output of
cat /home/cyberpanel/1048

[Errno 2] No such file or directory: ‘/home/backup/thejoy/userdata/cache.json’

backup E 2

Please provide proper details and information of your issue to address your issue.