Coonecting WebSocket with port 6001

Dear all,

I have an issue to open port 6001 for my websocket.

I tried many codes and still, it’s not open and i cannot fix it.

Best regards.

Which hosting provider are you using? Some hosting providers like Amazon AWS, Google cloud has their own firewall system where you need to whitelist the mentioned port number to make it work.


I am using

also, i put the port 6001 in whitelist in the firewall. Still, it does not work.

Best regards.

Did you try restarting the firewall after adding the port?

Try clearing all the browser cache and open the webapp in incognito mode and see if its working.

Dear all,

I disable the firewall for good but still, it is not working.


Best regards.

I believe you have already done all the vhost setup for the websocket and just trying to have it whitelisted on firewall as of now? Or the other steps are pending on your part?

You will need to make sure you have a working websocket proxy for this.
You can read more about it at Openlitespeed documentation

1 Like