.com website does not exist

Hello all. I’ve been having an issue for the last 2 weeks. When I add any .com domain to CP and try to manage it, I get: “This domain does not exist”. I have tried with 4 different domains, that are working fine with another ISP. I have re-install CP on 3 different VPS with different cloud providers, same issue. I don’t believe my domains are blacklisted, as they are more than 3 years old. If I add .co.uk or .net or .xyz domains, it works. Any one can assist please? Thanks

version ?
please screenshoot your version here

Hi. Thanks for the reply

Current Version : 2.3

Build : 1
Current Commit : 01a9093bdbc2bbf14c9ab67133c248588dd8b225

The screenshot not working for me, sorry

1 Like

have you try : slasdkljasdkljasdkasjdklajdkljkdljskljdakljdakda.com
and try add google.com

if that random .com success
then (if you can) sent the sscreen shoot of error here

It’s not the installation that does not work. It is when you want to manage it. If you add it’s ok, when you click on manage, then you get the error

Now go to Websites → List Websites → Manage. then you get the below

domain name from inbox

from your screenshoot above

Hi again, when you click MANAGE then that’s when I get the error! If I add another domain which is not .com, then I can manage, add wordpress, DNS… but NOT with any .com domains

you use 1core + 1gb ram ?
try give sone times about 1 min…
db need refresh sometimes

if still error
i dont know why… @shoaibkk @die2mrw007 perhaps can help

No, My Server is with Hetzner with 2 Core and 4GB RAM. Does it work for you when you click on Manage?

everything working

if you still no website inside your cyberpanel
better to re install it
do not user cyberpanel img from provider
just install the OS/distro
then install cyberpanel manually

Disable Modsecurity if its enabled. That should solve your problem. Its owasp ruleset which sometimes trigger this. Not a permanent solution though, but for time being try disabling it and add your domains. I am investigating which section of rules are triggering this.


Hi Leader
You are absolutely correct. That works!!! 5* Thanks

1 Like



i never use it actually
but who knows someday i will need it

What you do for secure your servers?
If I understand right you don’t use CSF and Modsecurity at all.

1 Like

i dont use anything
since i still use it for personal only
and run with vps under NAT

i only change ssh port
add website under reseller account

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.

Some time it cause the issue and @die2mrw007 is 100% right