Cloudflare Error 520 - I'm sick of this mistake!

Hello
I get this error on all my web sites especially wp-admin. Please do not hesitate to help, please.

http://prntscr.com/kscshk

Hello

Your origin server is reachable when you receive this error?

Yes I have access, no problem on other sites. some of my websites are doing this. and there is no problem with any other browser.

I have the same problem for a few days

Upgrade OpenLiteSpeed, see if your issue gets resolved, otherwise create a ticket at Submit Ticket - LiteSpeed Technologies

yum upgrade openlitespeed
Hello I get this error on all my web sites especially wp-admin. Please do not hesitate to help, please.

http://prntscr.com/kscshk

I am facing the same issue & figured out the Problem, it’s because of SSL is not installed on the Origin Server but you have enabled Full SSL on CloudFlare. Just change the CF SSL to Flexible, hope it will be fine.

Upgrade OpenLiteSpeed, see if your issue gets resolved, otherwise create a ticket at https://store.litespeedtech.com/store/submitticket.php?step=2&deptid=4
yum upgrade openlitespeed
I figured out the Problem, It's SSL issue, when I enabled Full SSL on CloudFlare, It's returning to 502 or 520 Error page, because SSL is not installed on Origin Sever.

And the Fact is, I have installed Let’s Encrypt SSL using CyberPanel, I also reissued 2 times to fix the Issue but not solved because CyberPanel actually not installing SSL, even it shows Success Message. I verified it.

OLS server is updated:


LiteSpeed/1.4.38 Open

How to fix this SSL Installation Bugs? Or install Let’s Encrypt SSL for that site/domain manually?

Two days ago, two of my ip’s got blocked in China. Can’t ssh into it. China is using AI now to censor now. Ss fixed. Minor disturbance.

I have the same issue can anyone please help?

Explain please?

websites are integrated with Cloudflare and got error always 520. I want to enable Cloudflare for my websites, how is it possible help.

also, most of the time sites are down can you please help Nitesh…