Cert VALIDATION ERROR(S): self signed certificate

Cert VALIDATION ERROR(S): self signed certificate
So email is encrypted but the recipient domain is not verified

I need to fix this issue because my WordPress website emails are not working now. How can I fix this issue?

I’m using Cloudflare DNS servers. Rainloop emails are working properly, but WordPress SMTP plugins are not config my email. So I need to fix this issue soon as possible, So you have an idea to fix this issue please tell me, It is a great help for me.

Did you check my guide here Achieve 10/10 Email score with CyberPanel!

I’m getting exactly the same error using checktls.com, @bogodasr did you manage to resolve? I’ve issued a Letsencrypt SSL certificate for mail.mydomain.com but checktls.com says it’s self-signed and “Cert Hostname DOES NOT VERIFY (mail.mydomain.com != www.example.com)”.

Thunderbird popsup a security warning with it’s add exception dialog box (certificate not trusted).

ssl-tools.net says there’s a “Hostname mismatch”.

ssllabs.com returns a grade A with no errors.

sslchecker.com says no certificate found for port 465. (Hosted on DigitalOcean and ports 465, 587, 993, 995 are all open for tcp both in the Cyberpanel and the DO firewalls).

@usmannasir I’ve followed you excellent guide adding SPF, DMARC, and PTR, however sending an email to mail-tester.com returns error 554 5.7.1 Recipient address rejected: Access denied.

Cyberpanel version 2.1.1 (SSL issued for Hostname).

First of all, Cyberpanel version you using is of way older version. Update it first!

Now upgraded to v2.3.1 but same issues were occurring except that the Cert Hostname is now ‘VERIFIED’ in checktls. I re-issued the certificate for the mail server but no change.

Previously the Rainloop admin login was hanging, that now works.

Trying to receive in Mozilla Thunderbird using port 993 or 995 with STARTTLS says it’s connected in the status bar but results in a connection timedout error; Using SSL/TLS results in a security exception dialog open and the Get Certificate’ button returns Unknown Identity. However email received ok by Outlook on port 995.

Sending in Mozilla Thunderbird using port 465 and SSL/TLS works; However sending in Outlook on port 465 results in error 554 5.7.1 : Recipient address rejected: Access denied.

I’ve followed the instructions here but no change.

if we talk SSL
i found this problem too
cannot confirm because reach limit
must wait until released…

but if talk about rainloop… etc…
because my hostname and email are working i do not face the problem