CentOS 7 with CyberPanel not supporting Unicode File names in the File Manager

All the file names not coming in Hebrew or in Arabic but as below only:


But in Mysql, it’s coming as Normal UTF-8 language so No images displayed because of that critical issue.

Please advise how to fix it?

Welcome @rabia Happy you are here

Try and upgrade the panel using this guide here:

sh <(curl https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh || wget -O - https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh)

If using a sudo user rather than root, try this:

sudo su - -c "sh <(curl https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh || wget -O - https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh)"

1 Like

Thanks a lot, Can you confirm it will not affect my existing Data / Websites / etc…

No. The script updates your CyberPanel installation only. Does not change any of your email accounts, websites or domains.

BTW, How I can check what is the current version of CyberPanel I have in my CentOS? (using bash)

Additional question! I’ve identified that when uploading the image file directly I see the name but when uploading Zip file the extract causing that issue in the File Manager (Upgrade should also help here)?

@Rabia first setup dynamic logging

  1. Run command touch /usr/local/CyberCP/debug
  2. Run upgrade/update
  3. Post contents of /home/cyberpanel/error-logs.txt

These commands are safe.If you want to fix your issues we need to start with these steps first to rule out:

  1. old CyberP version with its bugs (maybe they are fixed in current version)
  2. get more logs for debugging purposes
1 Like

It’s clear, but before that, let’s first identify the version of my CP.

Can you please explain how to get the version? I tried several commands but not able to get it.

Go to https://SERVER_URL:8090/base/versionManagment

1 Like


Proceed to CentOS 7 with CyberPanel not supporting Unicode File names in the File Manager - #6 by josephgodwinke

Do you know how to set default to the locale in the bash in CentOS with CyberPanel?


localedef -c -f UTF-8 -i en_US en_US.UTF-8
export LC_ALL=en_US.UTF-8

How I can keep this configuration in the CP by default?

There some workarounds. A popular one is:

nano /usr/local/CyberCP/CyberCP/settings.py

permanently change this line LANGUAGE_CODE = 'en' until next upgrade. Pick and choose language codes from nano /usr/local/CyberCP/loginSystem/views.py or from same file (/usr/local/CyberCP/CyberCP/settings.py) here:

    ('en', _('English')),
    ('cn', _('Chinese')),
    ('br', _('Bulgarian')),
    ('pt', _('Portuguese')),
    ('ja', _('Japanese')),
    ('bs', _('Bosnian')),
    ('gr', _('Greek')),
    ('ru', _('Russian')),
    ('tr', _('Turkish')),
    ('es', _('Spanish')),
    ('fr', _('French')),
    ('pl', _('Polish')),
    ('vi', _('Vietnamese')),
    ('it', _('Italian')),
    ('de', _('Deutsch')),
    ('id', _('Indonesian')),
    ('bn', _('Bangla')),

Finally reboot server

1 Like

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.