Can't Use Specific Branch With Git on a Domain Name

Hello,

I’m trying to setup the Git feature with one of my domain names and for some reason I can’t seem to select a branch in which I’m wanting the website to be committed, pushed, and pulled from and to.

When I click on the drop-down for the branch all that I see is a blank field and “*main” when I want to use my “alpha” branch.

I’m not sure If this is a bug, or I’m just not doing something right, or what have you.

I would appreciate any help!

Cheers,
Donald Louch, CEO and Founder of DevLexicon

This branch exists in your repo?

@usmannasir said:

This branch exists in your repo?

Thanks for your reply!

Yes this branch does already exists in the repo. I even tried creating a new branch from the Git feature on CyberPanel and that didn’t work either.

So after creating a new repo from the CyberPanel area and manually adding branches there I was able to get the ability to select different branches and such!

Digging in the file manager I presume if I had added
#/.git/>config

[branch “BRANCHNAME”]
remote = origin
merge = refs/heads/BRANCHNAME

it would’ve worked? Where I added
#/.git/>config

[remote “BRANCHNAME”]
url = git@github.com:USERNAME/REPONAME.git
fetch = +refs/heads/:refs/remotes/origin/BRANCHNAME