Can't Upload Files Via FTP/File Manager OR Install New Plugin

When I try to Instal a new plugin in WP I get asked to enter my FTP details to my webserver. Why does CP do this, instead of installing a plugin the normal way?

Anyway, I enter the right FTP details (I first test it with an FTP program and it connects,) but the connection does not work in WP when I enter the FTP details.

I think the same problem is also what is preventing me from being able to upload files/folders via file manager. I am also not able to upload files via FTP, even though I can connect.

Please note: this is not a post_max_file_size issue. I have a sufficient max size limit. Even a 1kb file does not upload.

My CP version is: 2.1. build is 2.

Is there anyone who can point me to a solution, please?

Hello @iamveryok Happy you are here

The FTP issue in WordPress is a result of insufficient permissions by WP core to upload plugins

Solution:

  1. Fix permissions by Going to https://SERVER_URL:8090/filemanager/mywordpress.com and click on Fix Permissions

  2. Workaround: force direct filesystem method by adding the following directive in wp-config.php so that wp core doesnt use ftp but downloads updates + plugins directly

define('FS_METHOD','direct');
  1. Workaround: Add ftp credentials fromhttps://SERVER_URL:8090/ftp/createFTPAccount to your WP config by adding the following directives:
define('FTP_USER', 'mywordpress_ftpuser');
define('FTP_PASS', 'ftppassword');
define('FTP_HOST', 'ftp.mywordpress.com');

Many thanks for your help. I tried all options.

  1. I clicked the Fir Permissions option. Not resolved.

  2. I entered the define(‘FS_METHOD’,‘direct’);. Thi does not work.

But since after doing the above 2, now when I try to install a plugin from WP dashboard, it is no longer asking me to enter FTP details. But instead,


the error message is now this: Installation failed: Could not create directory.

  1. When I enter my FTP details in my wp-config, I get the error in the attached image when I save the file.

Your site have any custom package?

@josephgodwinke
Problem solved. Many thanks.

@iamveryok

Good news! kindly mark the solution to help the community