Cant get rid of too many redirects loop

Please advise, I’ve tried all i could find on the internet to fix the error too many redirects loop, but I’m still getting error too many redirects…

(I’m using CyberPanel with Cloudflare for dns. Let’s encrypt SSL.)

This error occurred with me when I used cyberpanel www to non www redirect but I’ve removed it and still getting this error. I’ve purged browser, tried multiple browsers, and purged cloudflare…

I’ve also disabled all plugins using the active plugins table in the database… And as a further measure, I’ve also renamed the plugins folder in public_html.

I’ve also tried purging my cloudflare and switching between off, flexible and full on cloudflare ssl… I’ve also re-issued the ssl certificate with Let’s Encrypt on my cyberpanel dashboard…

And I’ve replaced the .htaccess with a default WordPress multisite htaccess… I’m still having this problem…

Could it maybe have something to do with the Vhost?.

How do I go about fixing this?

What do I do next?

Check your database wp option table and tell me what is in URL?

Set on PhpMyAdmin wp option table site URL to start with https://www

Hello salsync.

  1. When you say you “used cyberpanel www to non www redirect”, what exactly do you mean? (probably ovewrtite rules from .htaccess?)

  2. Is this a subdomain you are trying to setup, or a main domain? Please try to press “Fix Permissions” in File Manager because some times permissions are responsible for redirect loops (specially for subdomains).

  3. Make sure that the OvewriteRule for redirecting all http to https that you added to .htaccess has the same website URL with the Wordpress website URL in WP Settings (or in wp-config.php). If the first one is with www and the other is without www, you get a redirect loop. For example if you used:

RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$$1 [R,L]

make sure that in WP settings your URL is also (and not

1 Like