Can't connect my FTP - Installed on Google Cloud Platform

I created a new FTP user in the panel.
Tried to connect with FileZila and get error:
Error: Connection timed out after 20 seconds of inactivity
Error: Could not connect to server

In GCP I created a new firewall rule and opened the 21,40110-40210 ports.
Besides that, I had created SSH keys and updated them on GCP Metadata.
I’m able to connect to the GCP VM instance via FTP, but /home/ folder is restricted and I can’t access this folder, so this ain’t helped me.

Tried to search here in the forum, but there is no working solution.
I’ll be grateful if somebody has any solution for this.

Thank you

Thank you for your answer.
Successfully connected with WinSCP and SSH key that created and updated under security/firewall/secureSSH, but get the same error (like GCP connection) as when trying to open /home folder:

Error listing directory ‘/home’.

Permission denied.
Error code: 3
Error message from server: Permission denied

Any ideas?
Thank you