Cannot serve ECMAScript 6/2015 for ExpressJS NodeJS app

Hi everyone,

I am a bit confused. I haven’t made any changes on my website since December. And now suddenly I get a 404. It seems everything ok.

  1. Cloudflare DNS is pointing to my IP.
  2. My VPS server seems fine. No message error.
  3. Updated Cyberpanel
  4. Looked at the Error logs. kill the port and restarted.

Not sure what can be wrong. The only thing I see suspicious is that in website lists, my website shows Suspended. When going to “Manage” I can’t see an option where to activate it or unsuspend it.

Asked ChatGPT and has no idea.

Does anyone has an idea what can be wrong?

Appreciate your help enormous! It is crucial to restore the website

Welcome @zaesar Happy New Year

Go to https://SERVER_URL:8090/websites/siteState choose your website and un-suspend it.

Thanks for your response!

I’ve done what you suggested but now I get:

Web server is down Error code 521

Visit for more information.

Any suggestion of what I can do? Really appreciate your help!!

Error 521 means that your origin server does not respond to cf requests

Change your ssl encryptions mode to Flexible on cf

Purging the cf cache might also help

Should I do that on Cloudflare?

Thank you very much for taking your time!

Yes cf means cloudflare. Do that on cloudflare dashboard

If all fails disable Cloudflare if possible and try again

Yes! I’ve checked and it is already set to flexible

Any idea of what could be wrong?

Again and one hundred times. Thank you a lot!!

Is this a wordpress site? if it is disable plugins and try again.

Also check rewrite rules/.htaccess for conflict. Use the default wordpress .htaccess

Nope it is a React and NodeJs. Isee this message on the page: You








It looks like a Host Error

Is your server up? reboot it and try access through ssh terminal

Sorry how do I reboot?

Go to dashboard of your service provider and see if you can restart the vm there. Also you can try log into ssh terminal and see if you get in. If you get to log into server using ssh run these commands and post screenshot

# ubuntu
systemctl status lscpd
systemctl status lsws

# almalinux
service lsws status
service lscpd status

post for each command

Try disable your firewalls e,g, to disable firewalld that comes presintalled on cyberpanel

systemctl disable --now firewalld.service
firewall-cmd --state

Ok, now they are not running but still not working the website…


Restart litespeed and cyberpanel’s lscpd

systemctl restart lsws
systemctl restart lscpd

When running: ```
systemctl restart lsws

I get:
Job for lshttpd.service failed. See "systemctl status lshttpd.service" and "journalctl -xe" for details.

When running “systemctl status lshttpd.service” I get:

lshttpd.service - OpenLiteSpeed HTTP Server
Loaded: loaded (/usr/lib/systemd/system/lshttpd.service; enabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/lshttpd.service.d
Active: activating (start) since mié 2023-02-15 22:32:33 UTC; 17s ago
Control: 3748 (lswsctrl)
CGroup: /system.slice/lshttpd.service
├─3748 /bin/sh /usr/local/lsws/bin/lswsctrl start
└─3815 sleep 1

feb 15 22:32:33 aifilms-server.vps systemd[1]: lshttpd.service holdoff ti…
feb 15 22:32:33 aifilms-server.vps systemd[1]: Stopped OpenLiteSpeed HTTP…
feb 15 22:32:33 aifilms-server.vps systemd[1]: Starting OpenLiteSpeed HTT…
feb 15 22:32:34 aifilms-server.vps lswsctrl[3748]: [OK] litespeed: pid=3765.
Hint: Some lines were ellipsized, use -l to show in full.


/usr/local/lsws/bin/lswsctrl start