Cannot sent user mail.client-domain.tld

i test my smtp using wp mail smtp pro

when i put server host: mail.client-domain.tld
result error

but when i change the host to
everything is working

how to fix it ?

@die2mrw007 @shoaibkk @S4_Hosting and other ?
anyone ?

I have noticed same issue on when connecting mail box to gmail. Other one what give complain of mail server is outlook if don’t use main mail server domain.

1 Like

so, is this an issue/bug ? or just miss configuration ?

what do you think ?

i hope this is my mistake…
if not…then developer will have +1 homework

I think it’s something to do with some mail systems want actual sending mail server mach.

some past version (i forgot what month)
it’s working…
i can use mail.client-domain.tld
but few days ago it came to failure

I just checked I use same plugin free version on one site with own maiserver, that’s working fine even use not main mail server host

so… at your side, it’s working :frowning:
i tried free version too, same result… error :frowning:
omg… is this my local problems ?

When you send test mail what full error report say?

look like everythings is okay

WordPress: 6.0
WordPress MS: No
PHP: 8.0.20
WP Mail SMTP: 3.4.0

Mailer: smtp
Constants: No
ErrorInfo: SMTP Error: Could not connect to SMTP host.
Port: 465
SMTPSecure: ssl
SMTPAutoTLS: bool(true)
SMTPAuth: bool(true)

OpenSSL: OpenSSL 1.1.1f 31 Mar 2020
Apache.mod_security: No

Email Source: WP Mail SMTP Pro
Mailer: Other SMTP
SMTP Error: Could not connect to SMTP host.

SMTP Debug:
2022-06-13 09:05:08 Connection: opening to ssl://, timeout=300, options=array()

2022-06-13 09:05:08 Connection failed. Error #2: stream_socket_client(): SSL operation failed with code 1. OpenSSL Error messages:error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed [/home/ line 389]

2022-06-13 09:05:08 Connection failed. Error #2: stream_socket_client(): Failed to enable crypto [/home/ line 389]

2022-06-13 09:05:08 Connection failed. Error #2: stream_socket_client(): Unable to connect to ssl:// (Unknown error) [/home/ line 389]

2022-06-13 09:05:08 SMTP ERROR: Failed to connect to server: (0)

SMTP Error: Could not connect to SMTP host.


i just change to mail.primary-domain.tld then everything is working fine
mail.primary-domain.tld at cloudflare too

You already tried re-issue SSL for this mail domain?

already did…
thats why i post here
i affraid bug ssl is comming back

Need to check if you issue mail server SSL for any domain

i will try re issue other domain…

only happen to new added domain(new-issued)

forget it… i will let it use primary domain.

my head already smoked out

i hope it will solved in next 3 month hahaha

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.