Cannot modify rewrite rules/.htaccess

In CyberPanel 1.9.0, if I try to change and save the rewrite rules for any site, I get the following error:

Could not save rewrite rules. Error message: Traceback (most recent call last): File “/usr/local/CyberCP/plogical/”, line 25, in from vhost import vhost File “/usr/local/CyberCP/plogical/”, line 23, in from managePHP.phpManager import PHPManager File “/usr/local/CyberCP/managePHP/”, line 6, in from .models import * File “/usr/local/CyberCP/managePHP/”, line 9, in class PHP(models.Model): File “/usr/local/CyberCP/managePHP/”, line 10, in PHP phpVers = models.CharField(max_length=5,unique=True) File “/usr/lib64/python2.7/site-packages/django/db/models/fields/”, line 1057, in init super(CharField, self).init(*args, **kwargs) File “/usr/lib64/python2.7/site-packages/django/db/models/fields/”, line 172, in init self.db_tablespace = db_tablespace or settings.DEFAULT_INDEX_TABLESPACE File “/usr/lib64/python2.7/site-packages/django/conf/”, line 56, in getattr self._setup(name) File “/usr/lib64/python2.7/site-packages/django/conf/”, line 41, in _setup self._wrapped = Settings(settings_module) File “/usr/lib64/python2.7/site-packages/django/conf/”, line 110, in init mod = importlib.import_module(self.SETTINGS_MODULE) File “/usr/lib64/python2.7/importlib/”, line 37, in import_module import(name) ImportError: No module named settings

Should be fixed by doing an upgrade.

I also ran into the same problem, and I solved it by following these steps:

  1. pip install requests urllib3 pyOpenSSL --upgrade
  2. cd
  3. rm
  4. wget
  5. chmod +x
    6 ./

@usmannasir i just now did a fresh install of latest free cyberpanel using litespeed ent edition on vps CentOS 7
i also have the same issue, I am on the latest version 1.9 build 1?
i had to go to file manager and create .htaccess and write my rewrite rule there in the control panel>clicking rewrite rule the box opens you select the rewrite rule from your drop down and click save and get error, can’t save ?

I got the same error
Ver: 1.9.1

Fresh install after countless problems with CyberPanel… And STILL having this issue…

Same, unable to update rewrite rules via Cyberpanel, they are also ignored when i add to .htaccess manually.

Also found PHPMyAdmin and mysqldump not working on 1.91

Is there a fix for this yet? I’m also getting this error on CyberPanel 1.91.

I’m trying to modify the CyberPanel 1-click WordPress Cloud install (WP in a subdirectory) so that I can access my site via http://example/com instead of http://example/com/wordpress. I have modified docRoot to be $VH_ROOT/public_html/wordpress, and need to add rewrite rules, but get the error described above when I try to do so…

I am also having trouble with this error

Did you create almost identical domain names?
Cyberpanel will create the same user as “nameweb”
And maybe this has caused an error

i think if you can not modify Rewrite Rules on Cyberpanel . you need to check user of your website :smile:
#cat /etc/passwd
after that , share permission
chown -R username /home/yourdomain/public_html