Cannot access CyberPanel Dashboard after changing from port 8090

Hi, I changed my port number from default 8090 to 7017. Everything was fine, but few days back I tried to login my server via SSH. So, I was getting error, then I delete SSH key from my CyberPanel, Now I can access SSH but Cyberpanel Dashboard page not working. “This site can’t be reached”

Error message: HTTPSConnectionPool(host=‘XX.XXX.XX.185’, port=7017): Max retries exceeded with url: /cloudAPI/ (Caused by NewConnectionError(‘<urllib3.connection.HTTPSConnection object at 0x7f326709b880>: Failed to establish a new connection: [Errno 113] No route to host’))

How Can I fix this Please help.

Happy New Year @SuperPSX

Did you check your firewall if the port is still open

# allow the port
firewall-cmd --permanent --zone=public --add-port=7017/tcp

Do the same for any other firewalls you have

Hi, Thank you for your reply, I’m not command expert. Can you please send me command so I can just paste and check or fix?

Open ssh terminal and paste this

firewall-cmd --permanent --zone=public --add-port=7017/tcp
1 Like

I got the success message, but still not able to access my dashboard

Is there any command I can revert port number back to default one. I mean 7017 to 8090

Follow the instructions here Changing Default CyberPanel Port to 8443 - #9 by tmoore

Thank you for your fast response. 1st I’m not using Cloudflare. 2nd, I didn’t understand those steps.

Can I make it ```
firewall-cmd --permanent --zone=public --add-port=8090/tcp

Or changing port is not important, problem is, since I delete SSH key from CyberPanl Darshboard>SSH, I'm not able to access my dashboard.

Do step 3 and 4. then run firewall-cmd --permanent --zone=public --add-port=8090/tcp reboot the server and try to access cyberpanel dashboard

I found this guide:

edit it using your SSH
by typing
cd /usr/local/lscp/conf and press enter
the type: dir then press enter
it will show you a list of files we are going to edit the file with the name bind.conf
so type: nano bind.conf
the nano editor will open just change the port to 8090 and save it by pressing control X and yes to make changes.
the reboot the server by typing reboot. and you should be good to go.

It’s fixed, I think I just needed to reboot my server after this command

firewall-cmd --permanent --zone=public --add-port=7017/tcp

It’s accessible, but 7017 not 8090

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.