Can not connect SFTP via Filezilla or WinSCP

Hi, I’have a new VPS on hostinger. I can’t connect via SFTP. Writing to them they tell me that the SFTP connection data is the same as SSH. SSH connections (with private key) via Putty and FTP via Filezilla work correctly.

Last reply is: “In this case, as it is an external control panel, I suggest contacting their team directly, so they could look into it closer and provide a solution as to how to connect via SFTP correctly on the CyberPanel. Thank you for understanding”.

Can someone help me? Thank you

Sorry but what is the question here? Didn’t understood.

“SSH connections (with private key) via Putty”
Download WinSCP: WinSCP :: Official Site :: Download

Config your connection like:
image

Click advanced, ssh → authentication:

And done

password auth is enabled?

sftp

There are screenshot of error.

Is Cyber Panel to configure?

There can be several issues that may cause this:

  1. Check FTP ports are open, sometimes the passive ports aren’t open. Also check if the ports are been blocked by the Firewall, CSF (Server->Security-> Firewall)
  2. Check detailed dynamic logging for errors then come paste the errors you get when you retry
  3. Update server Pure-FTPD and download the latest version of the ftp client you are using on your machine

Did you manage to sort this issue out?
I have no problem connecting via SSH, but no luck with Transmit FTP or Chronosync, or SFTP (command line).

If I try to sftp root@xxx.xxx.xxx.xxx it’ll prompt for passphrase for key, and then I just get;
Connection closed.
Connection closed

I’ve tried tweaking sshd_config options but to no avail.
Firewall port is open. Tried with both password and key. My local known_hosts file gets updated with remote key but the connection just doesn’t happen.

FWIW I’m also using a Hostinger VPS but I can’t see how that’d be a factor.

Anything I should try in sshd_config? Is it possibly a permissions issue (eg. it’s not putting me in the right folder)? Which log would have info (can’t see anything in secure or messages)?