Can not be uploaded, Error message: 'file'

I’ve tried several times and it’s the same thing,
I’ve found a solution, and I’ve tried it all, but it doesn’t work.
Also, I also restarted php and server
I also changed the file name
upload_max_filesize\post_max_size I have also set them all

Current Version: 2.3
centos7
php7.4 and php8.1
my server is like this

Welcome @biubiu Happy you are here

You need to edit the PHP version you are using for that website:

  1. Go to https://SERVER_URL/managephp/editPHPConfigs

  2. Increase the php max execution/input time max_execution_time, max_input_time, upload_max_filesize to over 1gb, post_max_size

  3. Restart PHP

memory_limit
128M
max_execution_time
300
upload_max_filesize
2000M
post_max_size
1024M
max_input_time
120

Hi, my setup is like this

@josephgodwinke

Possibly you have a slow connection where upload is uploaded beyond the execution time. Adjust execution time. Personally i have an exectuion time of 3600 secs (a 60 minute upload) for users never had a complaint.

You can always configure this in a php.inifile, using

max_execution_time = 3600

@josephgodwinke

Hi, I changed max_execution_time = 3600 and it still doesn’t work, even after restarting php.
I have searched for a lot of solutions, but nothing works.
This is about vHost Conf. is there a problem here?

docRoot $VH_ROOT/public_html
vhDomain $VH_NAME
vhAliases www.$VH_NAME
adminEmails xxx@gmail.com
enableGzip 1
enableIpGeo 1

index {
useServer 0
indexFiles index.php, index.html
}

errorlog $VH_ROOT/logs/$VH_NAME.error_log {
useServer 0
logLevel WARN
rollingSize 10M
}

accesslog $VH_ROOT/logs/$VH_NAME.access_log {
useServer 0
logFormat “%h %l %u %t “%r” %>s %b “%{Referer}i” “%{User-Agent}i””
logHeaders 5
rollingSize 10M
keepDays 10
compressArchive 1
}

scripthandler {
add lsapi:sewbc9135 php
}

extprocessor sewbc9135 {
type lsapi
address UDS://tmp/lshttpd/sewbc9135.sock
maxConns 10
env LSAPI_CHILDREN=10
initTimeout 600
retryTimeout 0
persistConn 1
pcKeepAliveTimeout 1
respBuffer 0
autoStart 1
path /usr/local/lsws/lsphp74/bin/lsphp
extUser sewbc9135
extGroup sewbc9135
memSoftLimit 2047M
memHardLimit 2047M
procSoftLimit 65000
procHardLimit 68000
}

phpIniOverride {

}

module cache {
storagePath /usr/local/lsws/cachedata/$VH_NAME
}

rewrite {
enable 1
autoLoadHtaccess 1
}

context /.well-known/acme-challenge {
location /usr/local/lsws/Example/html/.well-known/acme-challenge
allowBrowse 1

rewrite {

}
addDefaultCharset off

phpIniOverride {

}
}

Kindly check the compressed file is it a healthy archive

@josephgodwinke
Uploading small zip files is possible, but 700m and 1G are not successful.

I’ll look at the error log, how can I change this?
“settings.DATA_UPLOAD_MAX_MEMORY_SIZE.”

[11.28.2022_11-38-49] [Errno 2] No such file or directory: ‘/etc/letsencrypt/live/sewbc.com/fullchain.pem’
[11.28.2022_11-39-50] /usr/local/lsws/lsphp74/etc/php.ini
[11.28.2022_11-57-40] /usr/local/lsws/lsphp81/etc/php.ini
[11.28.2022_11-57-54] /usr/local/lsws/lsphp54/etc/php.ini
[11.28.2022_12-04-34] Request body exceeded settings.DATA_UPLOAD_MAX_MEMORY_SIZE.
[11.28.2022_12-05-02] [Errno 2] No such file or directory: ‘/etc/letsencrypt/live/sewbc.com/fullchain.pem’
[11.28.2022_12-17-48] Request body exceeded settings.DATA_UPLOAD_MAX_MEMORY_SIZE.
[11.28.2022_12-24-11] Request body exceeded settings.DATA_UPLOAD_MAX_MEMORY_SIZE.
[11.28.2022_12-32-03] ‘list’ object has no attribute ‘find’
[11.28.2022_12-40-04] Request body exceeded settings.DATA_UPLOAD_MAX_MEMORY_SIZE.
[11.28.2022_12-40-50] ‘utf-8’ codec can’t decode byte 0x8b in position 724: invalid start byte
[11.28.2022_12-47-13] Request body exceeded settings.DATA_UPLOAD_MAX_MEMORY_SIZE.

See here. Increase upload_max_filesize . set this php.ini

memory_limit = 2000M
upload_max_size = 3500M
post_max_size = 3500M
upload_max_filesize = 3500M
max_execution_time = 7200
max_input_time = 7200
1 Like

Setup and use SFTP for bigger files.