BUG: Restore of Backup ist BROKEN - it searches for non existing public_html.tar.gz

I am trying to move my websites from one Cyberpanel installation to another.

I am using the REMOTE BACKUP tool to do this. Everything works fine until the restore aborts with an error message:

[01.31.2024_09-57-32] Restore aborted for: backup-mysite.info-01.31.2024_09-54-33.tar.gz. Error message: [Errno 2] No such file or directory: '/home/backup/transfer-4605/backup-mysite.info-01.31.2024_09-54-33/public_html.tar.gz' [736][5009]

I tried it several times. Then I also tried it manually, i.e. created a backup on the old system, copied it to /home/backup in the new system and tried to install it there with Restore.

It ends with the same error message.

According to the error message, a file “public_html.tar.gz” is being searched for within the transfer package.

But when I unpack the transfer package manually and look inside, there is no “public_html.tar.gz” as a file, but there is a folder.

I assume a new function should be implemented here which also implements the public_html directory packed in the transfer package, but this was not done in the BACKUP, but already implemented in the RESTORE?

I think it is a BUG.

Can anyone help?


PS: If I intervene manually in the transfer package and pack the public_html folder as tar.gz and integrate it into the transfer file, the restore runs without errors. So: Definitely a BUG

Fixed, please upgrade.

Thank you very much!