[BUG] Redirect when access port 8090 to phpmyadmin and not a panel

Update your cyberpanel…

great… now it’s not even loading on 8090… i’m getting an infinite loading screen…

edit: It took forever but seems ok now.

working smooth here… just open this first

https://yourdomain.tld:8090/logout

When go to phpmyadmin from the admin panel, it shows an error: Not Found The requested resource was not found on this server.

just update

Why is this issue marked as Solved? It’s not fking “solved”. “Reboot” is not the solution. “Upgrade” is not the solution.

it does…
login done
phpmyadmin done

. did you already upgrade ? what is your version ? post here

for ubuntu server its look like to use this first…
i have already create post about this to mr @usmannasir

Evidently there’s a new, NEW version of cyberpanel – the server I updated ~16 hours ago doesn’t work – the one I did :30 ago does. Doesn’t look like it got a new build number, though – still v2.3.2 even though it seems likely it’s really 2.3.3 or 2.3.2a.

do upgrade first…

Here I am, getting what I paid for…

whats is the matter to do upgrade ?

FYI
issu has gone after upgrade!

 sh <(curl https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh || wget -O - https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh)

try close browser then open https://domain.tld:8090/base

btw are u using ubuntu ?

image
ouch… new commit… brb upgrading

Hello.
Go to the following location:

/usr/local/CyberCP/public

Check if you have this, if you do delete the file:

index.php

The full location should be “/usr/local/CyberCP/public/index.php”

Looks like it was an error on either the phpmyadmin.zip or the extraction code, as the vps i updated yesterday had the same issue as everyone else, but the one i just updated doesnt.

So it was fixed, but on my case the index.php was still there affecting it.

1 Like

correct
and the update script already do this… (if im not wrong , i see that at github)
you can use https://domain.tld:8090/logout
that will call “other” login page.

What i mean was that who still has that issue, can delete that index.php file at that location, and then no need to add “logout” anymore, as it will be fixed :grinning:

How your “/usr/local/CyberCP/public” should be:
1

How it became yesterday:

Delete the extra files. Only who updated at the wrong time yesterday was affected it seems.

1 Like

but not all understand about that…
thats why i still hoping developer do “automatic” fix for that

There, its just copy-paste + enter at putty:

rm -rf /usr/local/CyberCP/public/doc
rm -rf /usr/local/CyberCP/public/examples
rm -rf /usr/local/CyberCP/public/js
rm -rf /usr/local/CyberCP/public/libraries
rm -rf /usr/local/CyberCP/public/locale
rm -rf /usr/local/CyberCP/public/setup
rm -rf /usr/local/CyberCP/public/sql
rm -rf /usr/local/CyberCP/public/templates
rm -rf /usr/local/CyberCP/public/themes
rm -rf /usr/local/CyberCP/public/vendor
rm -f /usr/local/CyberCP/public/babel.config.json
rm -f /usr/local/CyberCP/public/ChangeLog
rm -f /usr/local/CyberCP/public/composer.json
rm -f /usr/local/CyberCP/public/composer.lock
rm -f /usr/local/CyberCP/public/config.sample.inc.php
rm -f /usr/local/CyberCP/public/CONTRIBUTING.md
rm -f /usr/local/CyberCP/public/favicon.ico
rm -f /usr/local/CyberCP/public/index.php
rm -f /usr/local/CyberCP/public/LICENSE
rm -f /usr/local/CyberCP/public/package.json
rm -f /usr/local/CyberCP/public/print.css
rm -f /usr/local/CyberCP/public/README
rm -f /usr/local/CyberCP/public/RELEASE-DATE-5.1.3
rm -f /usr/local/CyberCP/public/robots.txt
rm -f /usr/local/CyberCP/public/show_config_errors.php
rm -f /usr/local/CyberCP/public/url.php
rm -f /usr/local/CyberCP/public/yarn.lock

If you need help send me message with your AnyDesk

2 Likes

actually my production server already fixed from yesterday…

i just trying to make the solution for other cyberpanel user that not understand cli

1 Like