Brotli static cache compression not working

I have an Ubuntu 20.04 install with OLS and CyberPanel. I have enabled Brotli in the OLS config via ip:7080.

When I run this Brotli Test, it says it isn’t enabled. If I disable GZIP at the vhost level, this GZIP Compression Test tells me it is no longer enabled. So, I know that the vhost config is working.

I tried entering brotli --help into ssh and it said it wasn’t installed. When I installed via apt install brotli, it still isn’t working. Should that have even been necessary? You’d think it would be installed by default with Ubuntu or at least OLS+CyberPanel.

Any ideas? Is there a setting in LSCache or CyberPanel that I should check?

Nevermind. It is working just fine. The keycdn tool just doesn’t work. When I checked the headers for the assets in the browser dev tools, it shows that BR is working. And if I disable brotli, it uses gzip which seems to be about 10% larger for this page load (3.4MB vs 3.1MB with brotli).

Also, you don’t need to install the apt install brotli package for it to work.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.