Blacklisted domain - but the domain does not contains hostname or any blacklisted domain

Im getting an error after updating to the latest commit.
The domain that im trying to create does not contains hostname or any other blacklisted domains.
I also tried to change the hostname or delete the socket.gethostname() from file but the problem isnt fixed.

When i change the server hostname im getting another error on Version Management

Current Commit: sudo: unable to resolve host “newhostname”: Name or service not known 9de252a75e62017702bd399f5014d306a1c8c7a0

I restarted server several times and i tried to relaunch an update, again the problem still exists.
Anyone to help me please?

CyberPanel is running on: Ubuntu 20.04
Current Version: 2.3
Build: 4
Current Commit: 9de252a75e62017702bd399f5014d306a1c8c7a0
Latest Version: 2.3
Latest Build: 4
Latest Commit: 9de252a75e62017702bd399f5014d306a1c8c7a0

Welcome @aldoxx Happy you are here

I recommend you search the forum first before raising a topic.

See this Error message: Blacklisted domain

Thank you for your reply!
I have explained the topic well and i have tried the method that is explained there but the problem still exist.
Do you have a more honest answer to this problem?

Try and run systemctl restart lscpd

Also it would be best if you tried to change your hostname using vnc or ssh for the moment and see if the issue disappears

I have changed the hostname form “localhost-web” to “heloworldsrv”

After that i used systemctl restart lscpd

Now lets go to create website after these changes

Here is the result! ERROR STILL EXISTS

Which domain are you using to create a website ? Because all those you are throwing at your server are not domains

Here is the domain that im trying to create a website, but i have tried also another domains , subdomains and the problem is for every domain that im trying.

The error shows for all domains you try - domains with different primary domains e.g. and

OR you are trying and

The problem exists only for
not for

@josephgodwinke do you have any idea for a possible solution?
This is a bug that must have attention.

Tried to replicate your issue on a new server and could not run into the same issue. Can you reprovision your VM or server and try again

I fixed this by changing all return 0 to return 1 on

i only changed this part of

    def checkOwnerProtection(currentACL, owner, child):
        if currentACL['admin'] == 1:
            return 1
        elif child.owner ==
            return 1
        elif child == owner:
            return 1
            return 1

    def CheckDomainBlackList(domain):
        import socket

        BlackList = [ socket.gethostname(), '', '', '', '', 'localhost', '', '',
                     '', '', '', '', '', '',
                     '', '', '', '', '', '', 'localhost.localdomain',
                     'localhost4.localdomain4', 'localhost6.localdomain6','', '', '',
                     '', '', '', '', '', '']

        DotsCounter = domain.count('.')

        for black in BlackList:
            if DotsCounter == 1:
                if domain == black:
                    return 1
                if domain.endswith(black):
                    return 1

        return 1

This was a temporary solution for me, but you can investigate more for this problem, somewhere its a bug.