Autorenew wildcard ssl certificate not working

Hello, thanks in advance for your time. I’m having problems with certbot and wildcard ssl certificates, I don’t know how to auto renew this kind of certificates.
I’m able to generate wildcard certificates with certbot, but then I need to add the wilrcard certificates by hand on cyberpanel web interface “add ssl”
The system just creates a selfsigned certificate. Any idea how to solve this?

Have you try this How to fix SSL issues in CyberPanel?

Hello Diego, were you able to solve this? Even if its manually renewing can you explaining the steps? I need wildcard for WP multisite. THx!

Nope, I’m still adding the wildcard certificate by hand in the “add ssl” feature of the site panel. The steps I’m doing right now are:
1) In CLI , renew or issue a certificate using acme.sh, /root/.acme.sh/acme.sh --renew -d yourdomain.com -d ‘*.yourdomain.com’ --dns --force --yes-I-know-dns-manual-mode-enough-go-ahead-please --cert-file /etc/letsencrypt/live/yourdomain.com/cert.pem --key-file /etc/letsencrypt/live/yourdomain.com/privkey.pem --fullchain-file /etc/letsencrypt/live/yourdomain.com/fullchain.pem
acme.sh will ask you, in this case, to create a txt record for the domain, something like _acme-challenge.yourdomain.com and give you tha txt record value.
2) In site panel, go to add SSL and copy the contents of the generated fullchain.pem to cert bot, and privkey.pem to the key box.

THank you Kindly. Are you trying to install Sites into Wordpress Multisite. Because I just realized a “Subdirectory” Install option allows you to AVOID using Wildcard SSL’s in favor of the Free Lets Encrypt ones via Aliases.