An error occurred while updating; Unable to create directory

Hello everyone, I have this problem when trying to update my plugins. It’s happening on all my VPS sites.
I selected a site to try to solve and Initially it asked for the ftp, I solved it by inserting the code: define(‘FS_METHOD’,‘direct’);

But it still displays the error: An error occurred while updating; Unable to create directory.

I followed all the steps in this guide:

Even so, I was not successful. I have the necessary permissions.

Any suggestions on how to resolve?

The version I’m currently on:

Current Version:
Current Commit:

Happy New Year @AMDark

What does the WordPress Site Health Tool tell you about your server configuration or file permissions ?

Post a screenshot here

Gravável = writable

public_html, wp-admin, wp-content: 0775

Using CyberPanel access your wordpress website filemanager and Click Fix Permissions and I got 1 error like this. can't access website + delete files : permission error - #8 by josephgodwinke

Hello, I applied Fix permissions and ran the commands:

$ chmod -R 777 /home/
$ chattr -R -ia /home/

I can update the plugins.

But now it has problems with the featured images and the header image, they now do not appear. I can upload images but when trying to insert them in topics or as highlighted they don’t work.
Not even the clickable links in the menu are working.


I still have the problem, the images in the posts do not appear, nor do the links in mine work.
I tried disabling plugins, changing theme and I still couldn’t solve it. Any solution?

Its a wordpress thing. Playa round with permalinks. If you are using a page builder check the links to these images it might be picking different images. For some buggy reason builders like wpbakery

Thank you for your attention, I tried several things but it didn’t work. I’ll create another VPS and restore from a backup. It will be faster.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.