All websites behind reverseproxy get error 400

Im running:

Current Version:




Current Commit:


Latest Version:


Latest Build:


Latest Commit:


And updated yesterday to this version from (last one before that)

How ever, after this update it seams something is going wrong when going trough my Nginx reverse proxy

All websites get a 400

And my error log shows me this:
2023-08-17 23:11:59.253695 [INFO] [3126] [] Status 400: Invalid charactor in header name: ‘X-ForProto -Proto’

I have not set any headers in the Nginx proxy manager since everything worked until yesterday when i did the upgrade. Is there any config file i need to edit or look over in order to solve this?

If needed i could set up a SSH user with su privileges.

Server is currently rocking Ubuntu Server 22.04.3 comming from 22.04.2 as well.
Worthy to note is that im running Wazuh client on the machine as well which seams to have messed up somthing with onlu wazuh-client (It is started and working but i get a dpkg error when ever i run an upgrade) and no, Imunify is not running nor is installed because of that reason.

I Also noticed that it only applies to previously created domains and not new domains. For what ever reason if i create a new website (with the same domain) it still gives me that same 400 error. but i i create a sub domain lets say test.mydomain,com it works no problems, if i then have removed mydomain,com and tries to put it up as a domain for the test.mydomain,com website it still gets that 400 error.

Anyone who can please help me before i have to put these websites on a new server?

Since i can’t wait any longer to solve this im setting up a new server and migrating databases and domains there.

The sad story is that all users need new accounts as well.

Even on a new install i have the same issue. Any solution?

For example, i can access my new controlpanel over at but i can not visit (It’s actually hosted in Cyberpanel)

I’m also in the same situation.

Oddly enough it was working a few months ago before doing a fresh install on a new VM yesterday.

Yepp, since i have some local websites hosted there i had to replace the panel since tyhere is currently no solution to this. CloudPanel saved me for now, but ill keep updating the Cyberpanel VM just in case it starts working again :smiley: Cyberpanel has a huge advantage over other hostingpanels by far, sad that some issues doesn’t get resolved in a timely manner tho.

I’ll try and check out cloudpanel, currenty checking out HestiaCP right now.

Now holding out updating my other production server as its running on an old 2.3.4 cyberpanel commit and works with nginx proxy manager just fine.

I have the same problem. I use Nginx as a reverse proxy and after the last update I only get code 400.

Captura de tela 2023-08-31 090526

And in the error logs I get:

Status 400: Invalid charactor in header name: 'X-ForProto -Proto'

I’m having to migrate all the sites, they all stopped working.

Solved it!

Rollback openlitespeed to version 1.7.16

The problem is on openlitespeed

1 Like

Do you mind sharing the steps for that?


Go here:
Choose distro and download the correct version of a previous openlitespeed package (ie. 1.17.16)
install it

That is actually it! Everything will work again!

That simple! Took me 8 hours of downtime of a PUBLIC sever to figure something this simple out!


I created just an account to say a massive thank you it worked great.

To Dowgrade follow:

CentOS Downgrade

You can downgrade to any specific version that the repository supports.

  1. Find all of the available versions from the repository
yum --showduplicates list openlitespeed


  1. Run the downgrade command with the version you need
yum downgrade openlitespeed-1.7.16

Like @Axelf , I just created an account to thank you for the solution.

1 Like

This save my life… Thank you!

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.