After Upgrading to 1.9.4 /etc/crontab is empty, setup for daily backup also gone

Hi Guys,

Anyone experienced this issue ?

I’ve checked 3 servers that I upgraded same result with 3

I’m using Centos 7 and OLS and I upgraded from 1.9.3 to 1.9.4 and 1.9.2 to 1.9.4 both same result

Please let me know if you experienced the same issue and if I should copy paste old crontabs such as bandwith update and auto backup etc.

This is how my /etc/crontab looks like right now

Website successfully created. [200]

For details see man 4 crontabs

Example of job definition:

.---------------- minute (0 - 59)

| .------------- hour (0 - 23)

| | .---------- day of month (1 - 31)

| | | .------- month (1 - 12) OR jan,feb,mar,apr …

| | | | .---- day of week (0 - 6) (Sunday=0 or 7) OR sun,mon,tue,wed,thu,fri,sat

| | | | |

* * * * * user-name command to be executed

Thats it. no critical updates etc as it was before

Same here. FYI, I created a GitHub issue: crontab empty after upgrade to 1.9.4 · Issue #243 · usmannasir/cyberpanel · GitHub

BTW @Zalcig, beware because this python script that was in crontab before the upgrade:

/usr/local/CyberCP/bin/python /usr/local/CyberCP/plogical/

seems to be related to the renewal of SSL certificates!

@gabrielcossette I think it was something with or sth. Maybe its better that its not renewing because litespeed fails also sometimes after creating SSL :frowning: do you experience the same? Also Wordpress has issues with uploading images after latest upgrade to 1.9.4 It starts to works when I restart the machine but after some time again it gives the error message :

Post-processing of the image failed. If this is a photo or a large image, please scale it down to 2500 pixels and upload it again.

I just updated to 2.0 and all of the existing (non cyberpanel) root cron jobs disappeared.

Which is not good (raid syncing / daily reporting / mysql backup /backups…).

I had backups…but still if I had not noticed today…my backups would have been out of date very quickly.

They are now in root user file in /var/spool/cron/root

You mis-understand…all of the NON-cyberpanel jobs in /var/spool/cron/root got deleted during the cyberpanel upgrade.

Like Bacula backups / automysqlbackups / raid resync / and disk space notification reports…none of these had anything to do with CP.

There was a /var/spool/cron/root file with cyberpannel jobs in it…but all previous contents were gone.

on Centos 7.8 btw

Same thing happened to me !! After updating cyberpanel.

I do but…

I can’t imagine running a public facing server without some non cyberpanel cron jobs.

CP does not handle most of the SYSTEM functions or anything like blocklists for Rspamd. CP is a tool for managing part of the server, but not all of it.

So the cyberpanel update script should not be wiping out the system cron config.


As I pointed out in all of my above posts I have daily backups…

So what are you telling me…I should not bring up issues with cyberpanel on the cyberpanel forum under bug report???