After installing CSF firewall, unable to resolve host, panel dead, doesn't load. Hostname?

I’ve been using this guide to set up Cyberpanel Hetzner Cloud Setup (New USA Location) - YouTube. When I got to 13:00 “turn on CSF (ConfigServer Security and Firewall)” it resulted in my panel access being completely broken/unresolvable.

I was accessing it via, but now neither that nor https://ip.ip.ip.ip:8443/firewall/csf work. And port 8090 doesn’t work either.

I’m using Cloudflare as my DNS so I changed the port to 8443 per Easiest way out there!! How to Fix the CyberPanel Port 8090 issue with Cloudflare!!! - YouTube

I’m trying to set up a forum on a subdomain I had the “hostname” as an abbreviation hostnamectl set-hostname abbr. I’m not sure if this contributed to the error? Should the hostname be “forum”? I had it set to initially, and that caused an error “black listed domainError message: Blacklisted domain. - YouTube.

When I clicked “install” for CSF the output showed:

sudo: unable to resolve host abbr: Name or service not known
Downloading CSF..

Extracting CSF..

Installing CSF..

And now Cyberpanel won’t load at all. I can still connect to my server via SSH. I changed the hostname to forum and restarted the server but Cyberpanel still doesn’t load.

My website loads.

I tried it again, following the instructions in the video Hetzner Cloud Setup (New USA Location) - YouTube. This time I changed the port to 8443 but didn’t change the hostname.

This time the firewall was not enabled by default and enabling it at 12:24 caused a new type of error:

 Origin is unreachable Error code 523
Visit for more information.
2023-06-28 01:25:02 UTC
Los Angeles
What happened?

The origin web server is not reachable.
What can I do?
If you're a visitor of this website:

Please try again in a few minutes.
If you're the owner of this website:

Check your DNS Settings. A 523 error means that Cloudflare could not reach your host web server. The most common cause is that your DNS settings are incorrect. Please contact your hosting provider to confirm your origin IP and then make sure the correct IP is listed for your A record in your Cloudflare DNS Settings page. Additional troubleshooting information here.

Toggling/disabling Cloudflare’s “proxy status” did not make a difference. Neither the IP nor load. So there seems to be some compatibility issue with Cloudflare.

Hey… go to ip.ip.ip.ip:8090

Yeah I did and it wasn’t working either.

I’m guessing that if we change the port from 8090 to 8443 we have to make sure 8443 is allowed in the CSF firewall config. I guess we have to SSH into our server and edit the CSF config manually to allow port 8443? Is it TCP in and out?

There are a few other threads discussing Cloudflare and Cyberpanel, but none seem to cover the issues I ran into. IE: Cloudflare and Cyberpanel CP