Admin Randomly Generated Password does not work on brand new install???

I have just performed a brand new cyberpanel install with openlightspeed.

I selected the option r (recomended) for admin password during installation.

After the install, i copied the exact login details to a wordpad document and then attempted to use these to login. (copy and paste)

Could Not Login, Error message: wrong-password.

I tried enterring them manually…same error. The random generated password is 100% not stored correctly in Cyberpanel after installation. something is wrong with the script.

how can this be?

You can reset thru ssh.
python /usr/local/CyberCP/plogical/ --password newpassword

Please be mind when finish installation , there are 2 password prompt out , one is for panel , one is of mysql database, don’t mistake them.

The mysql uses root account and password…the panel is admin. Pretty hard to muck that up.

I tested that random generator several dozens times and never failed me.

Please try if you can reproduce it:

in a clean system

script /root/cyberpanle.log
yum install curl wget -y
curl --silent -o 2>/dev/null
sh -x

after installation please PM me the log , or send me via Slack