Access denied for user 'cyberpanel'@'localhost' (using password: YES)")

I am updating control panel using below

sudo su - -c “sh <(curl || wget -O -”

The upgrade runs until it gives an error django.db.utils.OperationalError: (1045, “Access denied for user ‘cyberpanel’@‘localhost’ (using password: YES)”)
above command failed… as per code below

return func(*args, **kwargs)
File “/usr/local/CyberPanel/lib/python3.8/site-packages/django/db/backends/base/”, line 200, in connect
self.connection = self.get_new_connection(conn_params)
File “/usr/local/CyberPanel/lib/python3.8/site-packages/django/utils/”, line 26, in inner
return func(*args, **kwargs)
File “/usr/local/CyberPanel/lib/python3.8/site-packages/django/db/backends/mysql/”, line 234, in get_new_connection
return Database.connect(**conn_params)
File “/usr/local/CyberPanel/lib/python3.8/site-packages/MySQLdb/”, line 130, in Connect
return Connection(*args, **kwargs)
File “/usr/local/CyberPanel/lib/python3.8/site-packages/MySQLdb/”, line 185, in init
super().init(*args, **kwargs2)
django.db.utils.OperationalError: (1045, “Access denied for user ‘cyberpanel’@‘localhost’ (using password: YES)”)
above command failed…

my website is still runing 100% but cant access cyberpanel

tried running /etc/cyberpanel/mysqlPassword in command line and it gives Permsision denied

I have connected to the php my admin page and can also viee the databases

Try login as root and then run this script:

sh <(curl || wget -O -

Got it working this afternoon, for some reason my putty window on the database file side did not scroll down more than the page size, moved down rows with cursor keys and found the database and root user passwords.

I found that the update I ran from the cyberpanel upgrade tab in cyberpanel changed both passwords. As far as I know an update should only update and not overwrite passwords.

I saw many post of many users with the same issue and not really a clear indication what the issue is.

Thank you for reaching out with info.

After I changed the passwords above my cyberpanel loaded again to the login page.

Even the admin password was also not correct and I had to use the command in putty to change login password for admin user on cyberpanel

Once I got in, i returned to putty and ran the upgrade from there without any issues at all.

When I have time will document exactly from start to end what I did to get it running

1 Like