Aborted, Failed to run cp command during backup generation..[365] [5009]

I am facing problem while backup any website.

Following error is thrown during backup process
Aborted, Failed to run cp command during backup generation…[365] [5009]

And in the backup directory of the website being backed up, a public_html forlder and a meta.xml file is found. No DBs or anything else

Any suggestion

I started having this problem after upgrading Cyberpanel to the latest version,

While automatic backup continues when it sees this problem, when some domains get stuck in the form of “Backing up databases”, the backup process stops completely and gets stuck like that.

(By the way, when we check the backup folder, we can see that the sql dump file was created successfully.)

I saw a user who had the same problem on the Cyberpanel facebook page and solved the problem by deleting and recreating the database.

As I said, I had the problem of deleting public_html in the previous version and I switched to the latest version and I have these two problems with backup, does anyone have the same problems or have any idea about the solution?

Solved the problem

The problem is owernership problem.

The cp command that tries to be executed during the backup process cannot complete the backup process because of the files in public_html that are owened by another user.

This situation can usually occur in files retrieved from backup or manual copying.

How to solve it:

  1. Method
    cd /home/exampledomain.com/public_html
    chown -R username:username *

  2. Method
    You can easily fix it by entering the public_html directory in the File Manager and clicking the Fix Permissions button in the upper right corner.